Skip to content
Browse files

Remove the ActiveRecord hacks as they are properly deprecated in Rail…

…s 3.0
  • Loading branch information...
1 parent 28158b1 commit 174b62a259a5cfce80e523c1d328fcde795a3964 @wycats committed Aug 3, 2010
Showing with 0 additions and 13 deletions.
  1. +0 −1 rails_upgrade.rb
  2. +0 −12 rails_upgrade/active_record.rb
View
1 rails_upgrade.rb
@@ -57,7 +57,6 @@ def require_bundler
require "active_support/all"
require "rails_upgrade/action_controller"
-require "rails_upgrade/active_record"
require "rails_upgrade/action_view"
# This is needed because Rails 3 requires development.rb, while Rails 2.3
View
12 rails_upgrade/active_record.rb
@@ -1,12 +0,0 @@
-module ActiveRecord
- module ConnectionAdapters
- class AbstractAdapter
- def add_index(table_name, column_name, options = {})
- if options.key?(:name)
- options[:name] = options[:name].to_s
- end
- super
- end
- end
- end
-end

0 comments on commit 174b62a

Please sign in to comment.
Something went wrong with that request. Please try again.