My personal ESLint config.
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
__tests__
rules
scripts
.editorconfig
.gitattributes
.gitignore
.travis.yml
base.js
changelog.md
flow.js
index.js
license
package.json
preact.js
readme.md
yarn.lock

readme.md

eslint-config-wyze

Build Status npm devDependencies

My personal ESLint settings.

Installation

Note: The below commands will generate the command you will need to run for installation. You can replace yarn add --dev with npm i --save-dev if not using Yarn.

Base

(
  export PKG=eslint-config-wyze; npm info $PKG config.basePeers --json | command sed 's/[\{\},]//g ; s/: /@/g' | xargs echo yarn add --dev $PKG
)

Preact/React

(
  export PKG=eslint-config-wyze; npm info $PKG config.reactPeers --json | command sed 's/[\{\},]//g ; s/: /@/g' | xargs echo yarn add --dev $PKG
)

Flow

(
  export PKG=eslint-config-wyze; npm info $PKG config.flowPeers --json | command sed 's/[\{\},]//g ; s/: /@/g' | xargs echo yarn add --dev $PKG
)

Usage

package.json

{
  // React
  "eslintConfig": {
    "extends": "wyze"
  }

  // Preact
  "eslintConfig": {
    "extends": "wyze/preact"
  }

  // Non-React
  "eslintConfig": {
    "extends": "wyze/base"
  }

  // Flow
  "eslintConfig": {
    "extends": "wyze/flow"
  }

  // Multiple (React + Flow)
  "eslintConfig": {
    "extends": [
      "wyze",
      "wyze/flow"
    ]
  }
}

Peer Dependencies

Package Base Preact/React Flow
babel-eslint πŸ“¦
eslint πŸ“¦ πŸ“¦ πŸ“¦
eslint-config-airbnb πŸ“¦ πŸ“¦
eslint-plugin-eslint-comments πŸ“¦ πŸ“¦
eslint-plugin-flowtype πŸ“¦
eslint-plugin-import πŸ“¦ πŸ“¦
eslint-plugin-jsx-a11y πŸ“¦
eslint-plugin-react πŸ“¦
eslint-plugin-wyze πŸ“¦ πŸ“¦

Change Log

Full Change Log

v5.0.0 (2017-04-02)

  • [facbd4e68b] - Upgrade dependencies (Neil Kistner)
  • [5a278abd00] - Update readme and installation method (Neil Kistner)
  • [c8476650de] - Add eslint-comments plugin (Neil Kistner)
  • [3d20212e92] - Enable rules for eslint-plugin-jsx-a11y@4 and require overrides (Neil Kistner)
  • [6162b2b688] - Exclude test files from npm package (Neil Kistner)
  • [3265224d17] - Upgrade dependencies (Neil Kistner)
  • [3e2283e267] - Update version script to skip beta releases in changelog (Neil Kistner)
  • [63f1686355] - Enable some eslint-plugin-jsx-a11y rules (Neil Kistner)
  • [c7fd8556ff] - Enable react/void-dom-elements-no-children rule (Neil Kistner)
  • [62c1ebcf45] - Relax react/sort-prop-types rule (Neil Kistner)
  • [f3c9fe769f] - Remove react rules enforced by AirBnb (Neil Kistner)
  • [cd4a6a1d29] - Relax react/jsx-sort-props rule (Neil Kistner)
  • [57c75e3d9d] - Add past changelog and changelog build script (Neil Kistner)
  • [a878cce34a] - Fix build (Neil Kistner)
  • [b1fa5888f7] - Upgrade dependencies (Neil Kistner)
  • [645d72e356] - Fixing lint errors (Neil Kistner)
  • [8f666bbf5d] - Streamline test process a little more (Neil Kistner)
  • [763c78b238] - Always enforce space in arrays, no exceptions (Neil Kistner)
  • [ec0c03368d] - Remove max-len rule and fall back to AirBnb's (100 char) (Neil Kistner)
  • [96569b19a8] - Remove id-blacklist rule and use AirBnb's setting (Neil Kistner)
  • [bc33e5b42c] - Switch to Jest for testing (Neil Kistner)
  • [62302e6d52] - Quick project cleanup (Neil Kistner)

License

MIT Β© Neil Kistner