Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Android previewer issues and Visual Studio 2017 XAML formatting issues #4851

Open
andreinitescu opened this Issue Dec 23, 2018 · 4 comments

Comments

Projects
None yet
4 participants
@andreinitescu
Copy link
Contributor

andreinitescu commented Dec 23, 2018

Description

Please checkout the video
https://www.youtube.com/watch?v=OPjuBA0zlno&feature=youtu.be

The issues showed in the video are (in the same order I recorded in the video) :

  1. After creating a project and building it, opening the previewer doesn't show the preview.
    In order to see the preview before starting my work, I have to do a small change just to trigger the preview.

  2. Android previewer (iOS previewer seems to work): Setting FontSize is not reflected in the preview

  3. Android previewer (iOS previewer seems to work): Setting RotationX/Y is not reflected in the preview

  4. Very annoying and important: Formatting the XAML does not work.
    (I noticed that even if sometimes it works, it breaks after a while, the formatting just stops working. Trying to fix it by reopening the XAML and/or rebuilding the project doesn't work).

/cc @alanmcgovern @drewgillies

Steps to Reproduce

Please see the video

Expected Behavior

Actual Behavior

Basic Information

  • Version with issue:
  • Last known good version: ¯\_(ツ)_/¯
  • IDE: Visual Studio 2017 Enterprise, v15.9.4
  • Platform Target Frameworks:
    • Android: The default of the Xamarin Forms project template (Android 8.1)

Screenshots

Reproduction Link

VS bug #756305

@StephaneDelcroix

This comment has been minimized.

Copy link
Member

StephaneDelcroix commented Jan 2, 2019

@PureWeen PureWeen moved this from New to External in Triage Jan 5, 2019

@samhouts samhouts moved this from External to Ready For Work in Triage Mar 6, 2019

@samhouts samhouts moved this from Ready For Work to Needs Estimate in Triage Mar 6, 2019

Triage automation moved this from Needs Estimate to Closed Mar 14, 2019

@andreinitescu

This comment has been minimized.

Copy link
Contributor Author

andreinitescu commented Apr 11, 2019

Setting the RotationX/Y property is still not working in VS2019.

@StephaneDelcroix

This comment has been minimized.

Copy link
Member

StephaneDelcroix commented Apr 15, 2019

@samhouts samhouts removed this from Closed in Triage Apr 15, 2019

@drewgillies

This comment has been minimized.

Copy link

drewgillies commented Apr 16, 2019

Have reactivated this bug internally. @StephaneDelcroix @samhouts @alanmcgovern

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.