Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[iOS] Label HorizontalTextAlignment="Center" not working in conjunction with LineHeight on iOS #4275

Merged
merged 11 commits into from Nov 6, 2018

Conversation

@masonyc
Copy link
Contributor

commented Oct 31, 2018

Label HorizontalTextAlignment="Center" not working in conjunction with LineHeight on iOS

Description of Change

Changed span.ToAttributed method to set the text alignment for the attributed text in iOS.

Issues Resolved

API Changes

None

Platforms Affected

  • iOS

Behavioral/Visual Changes

In iOS, when Horizontal Text Alignment and Line Height both set now will do the alignment correctly on label.

Before/After Screenshots

Before
previous

After
after

Testing Procedure

Start ControlGallery.iOS, Search and go to G4262 Page in tests screen, Two labels should both be centered.

masonyc added 2 commits Oct 31, 2018
fix issue#4262
Label HorizontalTextAlignment="Center" not working in conjunction with LineHeight on iOS

@masonyc masonyc changed the title [iOS] Label HorizontalTextAlignment="Center" not working in conjunction with LineHeight on iOS #4262 [iOS] Label HorizontalTextAlignment="Center" not working in conjunction with LineHeight on iOS Oct 31, 2018

@PureWeen PureWeen added this to In Review in v3.6.0 Nov 1, 2018

@PureWeen PureWeen requested review from hartez and samhouts Nov 1, 2018

@samhouts

This comment has been minimized.

Copy link
Member

commented Nov 1, 2018

build --uitests

@samhouts
Copy link
Member

left a comment

A small change for maintainability requested, but looks good otherwise. Thanks!

@samhouts samhouts added the e/4 🕓 label Nov 2, 2018

@samhouts

This comment has been minimized.

Copy link
Member

commented Nov 2, 2018

build --uitests

@samhouts samhouts moved this from In Review to In Progress in v3.6.0 Nov 2, 2018

@masonyc

This comment has been minimized.

Copy link
Contributor Author

commented Nov 2, 2018

The build failed, what was the error?

@samhouts

This comment has been minimized.

Copy link
Member

commented Nov 2, 2018

hmm, it was internal. let me try again!

@samhouts

This comment has been minimized.

Copy link
Member

commented Nov 2, 2018

build --uitests

@hartez

This comment has been minimized.

Copy link
Member

commented Nov 2, 2018

The build failed, what was the error?

Looks like it's not building because you remove the Xamarin.Forms.Build submodule. Revert those changes on your PR and it should build.

Revert "merge"
This reverts commit 939b6e1.
@masonyc

This comment has been minimized.

Copy link
Contributor Author

commented Nov 2, 2018

@hartez @samhouts Sorry, I have reverted the changes now.

Revert "merge"
This reverts commit 939b6e1.
@hartez
Copy link
Member

left a comment

Looks good, UI tests are passing; just have one minor change I'd like to the test case.

@hartez
hartez approved these changes Nov 6, 2018

@hartez hartez merged commit af0bc40 into xamarin:master Nov 6, 2018

1 check passed

license/cla All CLA requirements met.
Details

v3.6.0 automation moved this from In Progress to Done Nov 6, 2018

@samhouts samhouts added this to the 4.0.0 milestone Dec 4, 2018

@samhouts samhouts removed this from Done in v3.6.0 Jan 3, 2019

@samhouts samhouts modified the milestones: 4.0.0, 3.5.0 Jan 10, 2019

@samhouts samhouts added this to Done in v3.5.0 Jan 11, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
4 participants
You can’t perform that action at this time.