Skip to content
Newer
Older
100644 60 lines (47 sloc) 1.3 KB
03779e1 Start Rails 3.2 upgrade
Gabriel Evans authored Jan 20, 2012
1 source 'https://rubygems.org'
3f111df @jasoncheow Upgrade to Rails 3 by replacing default Rails generated files where a…
jasoncheow authored Nov 13, 2010
2
03779e1 Start Rails 3.2 upgrade
Gabriel Evans authored Jan 20, 2012
3 gem 'rails', '3.2.0.rc2'
3f111df @jasoncheow Upgrade to Rails 3 by replacing default Rails generated files where a…
jasoncheow authored Nov 13, 2010
4
5 # Bundle edge Rails instead:
6 # gem 'rails', :git => 'git://github.com/rails/rails.git'
7
03779e1 Start Rails 3.2 upgrade
Gabriel Evans authored Jan 20, 2012
8 # Gems used only for assets and not required
9 # in production environments by default.
10 group :assets do
11 gem 'sass-rails', '~> 3.2.3'
12 gem 'coffee-rails', '~> 3.2.1'
a30dea3 Reorganize assets to serve through Rails' asset pipeline
Gabriel Evans authored Jan 20, 2012
13
14 gem 'uglifier', '>= 1.0.3'
03779e1 Start Rails 3.2 upgrade
Gabriel Evans authored Jan 20, 2012
15 end
16
8dd39fd @BanzaiMan JRuby compatibility. We require RedCloth 4.2.7 here, since it is the …
BanzaiMan authored Nov 3, 2011
17 platforms :ruby do
18 gem 'sqlite3-ruby', :require => 'sqlite3'
19 end
20
21 platforms :jruby do
22 gem 'activerecord-jdbcsqlite3-adapter'
23 gem 'trinidad'
24 gem 'jruby-openssl'
25 end
3f111df @jasoncheow Upgrade to Rails 3 by replacing default Rails generated files where a…
jasoncheow authored Nov 13, 2010
26
a30dea3 Reorganize assets to serve through Rails' asset pipeline
Gabriel Evans authored Jan 20, 2012
27 gem 'jquery-rails'
28
3f111df @jasoncheow Upgrade to Rails 3 by replacing default Rails generated files where a…
jasoncheow authored Nov 13, 2010
29 # Use unicorn as the web server
30 # gem 'unicorn'
31
32 # Deploy with Capistrano
33 # gem 'capistrano'
34
35 # To use debugger
36 # gem 'ruby-debug'
37
38 # Bundle the extra gems:
03779e1 Start Rails 3.2 upgrade
Gabriel Evans authored Jan 20, 2012
39 gem 'RedCloth', '~> 4.2.9', :require => 'redcloth'
3f111df @jasoncheow Upgrade to Rails 3 by replacing default Rails generated files where a…
jasoncheow authored Nov 13, 2010
40 gem 'ruby-openid', :require => 'openid'
41 gem 'rack-openid', :require => 'rack/openid'
ac3d3ad @xaviershay Use a better version of Chronic, remove hack in Post model
authored Nov 14, 2010
42 gem 'aaronh-chronic', :require => 'chronic' # Fixes for 1.9.2
3f111df @jasoncheow Upgrade to Rails 3 by replacing default Rails generated files where a…
jasoncheow authored Nov 13, 2010
43 gem 'coderay'
44 gem 'lesstile'
45 gem 'formtastic'
03779e1 Start Rails 3.2 upgrade
Gabriel Evans authored Jan 20, 2012
46 gem 'will_paginate', '~> 3.0.2'
3f111df @jasoncheow Upgrade to Rails 3 by replacing default Rails generated files where a…
jasoncheow authored Nov 13, 2010
47
48 # Bundle gems for the local environment. Make sure to
49 # put test-only gems in this group so their generators
50 # and rake tasks are available in development mode:
51 group :development, :test do
75bfa5e Upgrade Cucumber configs, fix feature steps, and add cucumber-webstep…
Gabriel Evans authored Jan 20, 2012
52 gem 'database_cleaner'
a73bbc2 @xaviershay Get features running (but still failing)
authored Nov 14, 2010
53 gem 'cucumber-rails'
75bfa5e Upgrade Cucumber configs, fix feature steps, and add cucumber-webstep…
Gabriel Evans authored Jan 20, 2012
54 gem 'cucumber-websteps'
3f111df @jasoncheow Upgrade to Rails 3 by replacing default Rails generated files where a…
jasoncheow authored Nov 13, 2010
55 gem 'factory_girl'
56 gem 'rspec'
57 gem 'rspec-rails'
5a52fba @xaviershay Remove hpricot, upgrade nokogiri for windows compat (I hope). Fixes #34.
authored Nov 12, 2011
58 gem 'nokogiri', '~> 1.5.0'
3f111df @jasoncheow Upgrade to Rails 3 by replacing default Rails generated files where a…
jasoncheow authored Nov 13, 2010
59 end
Something went wrong with that request. Please try again.