Skip to content

nokogiri-1.4.4-x86-mingw32 #34

Closed
stevesharp opened this Issue Apr 28, 2011 · 3 comments

2 participants

@stevesharp

I followed the install instructions for Enki (On a windows 7 box) and have run up against the following error:

rake aborted!
127: The specified procedure could not be found. - Init_nokogiri

From what I can tell, I need to use the 1.4.4.1 version of nokogiri (Which I installed) which fixes the bug. I am just not sure what needs to be done to have Enki use this instead.

I am new to Rails, so I am not sure if this is really an Enki issue or just an issue related to something I have messed up.

Any help would be appreciated.

Thanks,
Steve

Output from my rake command follows:

C:\Users\ssharp\Documents\My Dropbox\Rails\Enki\enki>rake
(in C:/Users/ssharp/Documents/My Dropbox/Rails/Enki/enki)
rake aborted!
127: The specified procedure could not be found. - Init_nokogiri
C:/Ruby192/lib/ruby/gems/1.9.1/gems/nokogiri-1.4.4-x86-mingw32/lib/nokogiri/1.9/nokogiri.so
C:/Ruby192/lib/ruby/gems/1.9.1/gems/nokogiri-1.4.4-x86-mingw32/lib/nokogiri/nokogiri.rb:1:in require'
C:/Ruby192/lib/ruby/gems/1.9.1/gems/nokogiri-1.4.4-x86-mingw32/lib/nokogiri/nokogiri.rb:1:in
'
C:/Ruby192/lib/ruby/gems/1.9.1/gems/nokogiri-1.4.4-x86-mingw32/lib/nokogiri.rb:13:in require'
C:/Ruby192/lib/ruby/gems/1.9.1/gems/nokogiri-1.4.4-x86-mingw32/lib/nokogiri.rb:13:in
'
C:/Ruby192/lib/ruby/gems/1.9.1/gems/webrat-0.7.3/lib/webrat.rb:2:in require'
C:/Ruby192/lib/ruby/gems/1.9.1/gems/webrat-0.7.3/lib/webrat.rb:2:in
'
C:/Ruby192/lib/ruby/gems/1.9.1/gems/bundler-1.0.12/lib/bundler/runtime.rb:68:inrequire'
C:/Ruby192/lib/ruby/gems/1.9.1/gems/bundler-1.0.12/lib/bundler/runtime.rb:68:in
block (2 levels) in require'
C:/Ruby192/lib/ruby/gems/1.9.1/gems/bundler-1.0.12/lib/bundler/runtime.rb:66:ineach'
C:/Ruby192/lib/ruby/gems/1.9.1/gems/bundler-1.0.12/lib/bundler/runtime.rb:66:in
block in require'
C:/Ruby192/lib/ruby/gems/1.9.1/gems/bundler-1.0.12/lib/bundler/runtime.rb:55:ineach'
C:/Ruby192/lib/ruby/gems/1.9.1/gems/bundler-1.0.12/lib/bundler/runtime.rb:55:in
require'
C:/Ruby192/lib/ruby/gems/1.9.1/gems/bundler-1.0.12/lib/bundler.rb:120:in require'
C:/Users/ssharp/Documents/My Dropbox/Rails/Enki/enki/config/application.rb:12:in
'
internal:lib/rubygems/custom_require:29:in require'
<internal:lib/rubygems/custom_require>:29:in
require'
C:/Users/ssharp/Documents/My Dropbox/Rails/Enki/enki/Rakefile:4:in <top (required)>'
C:/Ruby192/lib/ruby/1.9.1/rake.rb:2373:in
load'
C:/Ruby192/lib/ruby/1.9.1/rake.rb:2373:in raw_load_rakefile'
C:/Ruby192/lib/ruby/1.9.1/rake.rb:2007:in
block in load_rakefile'
C:/Ruby192/lib/ruby/1.9.1/rake.rb:2058:in standard_exception_handling'
C:/Ruby192/lib/ruby/1.9.1/rake.rb:2006:in
load_rakefile'
C:/Ruby192/lib/ruby/1.9.1/rake.rb:1991:in run'
C:/Ruby192/bin/rake:31:in

'

@xaviershay
Owner

Try adding a dependency to the Gemfile:

gem 'nokogiri', '~> 1.4.4.1'

then run bundle install and see if it all works.

@stevesharp

Worked a treat!

I also had to comment out "hpricot" from the development / test section to get rake db:migrate to work.

Thanks for your help!

Ta,
Steve

@stevesharp stevesharp closed this Apr 29, 2011
@xaviershay xaviershay reopened this Apr 29, 2011
@xaviershay
Owner

bundler has a "platform" option I think to restrict certain gems to different OSes. That's probably the correct way to do it, though perhaps hpricot isn't required anymore or could be subbed out for nokogiri... If you felt up to it maybe see if you can put a pull request together?

Reopening until this is fixed in master.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.