Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Merge branch 'gemify'

  • Loading branch information...
commit 1e203cfe6534bc883caa6e3e4d803f1fd15acd05 2 parents 6d35aa8 + feab83a
Xavier Shay authored
2  .gitignore
View
@@ -1,2 +1,4 @@
*.ly
*.pdf
+pkg/
+*.gem
4 Gemfile
View
@@ -0,0 +1,4 @@
+source 'http://rubygems.org'
+
+# Specify your gem's dependencies in ..gemspec
+gemspec
26 Gemfile.lock
View
@@ -0,0 +1,26 @@
+PATH
+ remote: .
+ specs:
+ roborabb (0.0.1)
+
+GEM
+ remote: http://rubygems.org/
+ specs:
+ diff-lcs (1.1.3)
+ rake (0.9.2.2)
+ rspec (2.7.0)
+ rspec-core (~> 2.7.0)
+ rspec-expectations (~> 2.7.0)
+ rspec-mocks (~> 2.7.0)
+ rspec-core (2.7.1)
+ rspec-expectations (2.7.0)
+ diff-lcs (~> 1.1.2)
+ rspec-mocks (2.7.0)
+
+PLATFORMS
+ ruby
+
+DEPENDENCIES
+ rake
+ roborabb!
+ rspec (~> 2.0)
5 HISTORY.md
View
@@ -0,0 +1,5 @@
+# History
+
+## 0.0.1 / 10 December 2011
+
+* Initial release
12 Rakefile
View
@@ -0,0 +1,12 @@
+#!/usr/bin/env rake
+require "bundler/gem_tasks"
+
+begin
+ require 'rspec/core/rake_task'
+
+ RSpec::Core::RakeTask.new(:spec)
+
+ task :default => :spec
+rescue LoadError
+ $stderr.puts "rspec not available, spec task not provided"
+end
2  lib/roborabb.rb
View
@@ -1,6 +1,8 @@
require 'ostruct'
alias :L :lambda
+require 'roborabb/version'
+
class Roborabb
class Lilypond
def initialize(generator, opts)
3  lib/roborabb/version.rb
View
@@ -0,0 +1,3 @@
+class Roborabb
+ VERSION = "0.0.1"
+end
28 roborabb.gemspec
View
@@ -0,0 +1,28 @@
+# -*- encoding: utf-8 -*-
+require File.expand_path('../lib/roborabb/version', __FILE__)
+
+Gem::Specification.new do |gem|
+ gem.authors = ["Xavier Shay"]
+ gem.email = ["hello@xaviershay.com"]
+ gem.description = %q{Algorithmically generate practice drum scores}
+ gem.summary = %q{
+ Algorithmically generate practice drum scores. Customize algorithms with
+ ruby with an archaeopteryx-inspired style, output to lilypond format.
+ }
+ gem.homepage = "http://github.com/xaviershay/roborabb"
+
+ gem.executables = []
+ gem.files = Dir.glob("{spec,lib}/**/*.rb") + %w(
+ README.md
+ HISTORY.md
+ Rakefile
+ roborabb.gemspec
+ )
+ gem.test_files = Dir.glob("spec/**/*.rb")
+ gem.name = "roborabb"
+ gem.require_paths = ["lib"]
+ gem.version = Roborabb::VERSION
+ gem.has_rdoc = false
+ gem.add_development_dependency 'rspec', '~> 2.0'
+ gem.add_development_dependency 'rake'
+end
Please sign in to comment.
Something went wrong with that request. Please try again.