New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

pvr.mythtv recordings playback results in an immediate death #837

Open
ssakatausa opened this Issue Mar 26, 2017 · 11 comments

Comments

Projects
None yet
2 participants
@ssakatausa

ssakatausa commented Mar 26, 2017

On RPi3, XBian 2017.03.24, XBian 2017.03.17, and XBian 2017.03.10 fail to play recorded TV programs through the pvr.mythtv addon, while XBian 2017.03.03 is not subject to the problem. To replicate the problem:

  1. After fresh installation of any of the three versions of XBian, just set the IP address of the mythtv backend in the configuration screen of pvr.mythtv and enable pvr.mythtv.
  2. Click any in the list of the recorded programs to start the video playback.

This immediately results in the black screen. Kodi reacts to no keyboard input or mouse movement. Also, neither ssh access to the RPi3 not ping to the RPi3 works (the network seems to be down). The only thing I can do at this point is to unplug and re-plug the power cable to give a hard rest to the RPi3. Unfortunately, the log file contains no information about the problem, probably because the machine dies before any information about the recording playback is written to the log file.

By the way, I have already tried the latest version of pvr.mythtv (5.0.10) and found that it makes no difference. I hope that you can fix the problem. I will stick with XBian 2017.03.03 until then. Thanks!

@mkreisl

This comment has been minimized.

Show comment
Hide comment
@mkreisl

mkreisl Mar 26, 2017

Contributor

@ssakatausa

Do not have test environment for mythtv, so can not figure out where the problem is.

Two major packages were updated (Kodi = xbian-package-xbmc and Kernel = linux-image-bcm2836) but none of those packages between Mar 03 and 10, only cec library has been updated on Mar 08.

So could you please update package for package and see if it still works?

Thanks

Contributor

mkreisl commented Mar 26, 2017

@ssakatausa

Do not have test environment for mythtv, so can not figure out where the problem is.

Two major packages were updated (Kodi = xbian-package-xbmc and Kernel = linux-image-bcm2836) but none of those packages between Mar 03 and 10, only cec library has been updated on Mar 08.

So could you please update package for package and see if it still works?

Thanks

@ssakatausa

This comment has been minimized.

Show comment
Hide comment
@ssakatausa

ssakatausa Mar 27, 2017

Thanks for your comment, mkreisl. I'll try what you suggested.

ssakatausa commented Mar 27, 2017

Thanks for your comment, mkreisl. I'll try what you suggested.

@ssakatausa

This comment has been minimized.

Show comment
Hide comment
@ssakatausa

ssakatausa Mar 31, 2017

I am sorry that I could not try your suggestion earlier. Starting with a new installation of XBian 2017.03.03, I today upgrade all upgradable packages one by one. The upgradable packages were:

btrfs-tools
linux-image-bcm2836
xbian-package-config-shell
xbian-package-firmware
xbian-package-repo
xbian-package-xbmc
xbian-update

I have found that the problem of pvr.mythtv recordings playback happens as soon as linux-image-bcm2836 is upgraded from 4.4.48+-1486919396 to 4.9.17+-1490545026. I have also verified that the upgrade of the packages does cause the problem if linux-image-bcm2836 is not upgraded.

Best,

S

ssakatausa commented Mar 31, 2017

I am sorry that I could not try your suggestion earlier. Starting with a new installation of XBian 2017.03.03, I today upgrade all upgradable packages one by one. The upgradable packages were:

btrfs-tools
linux-image-bcm2836
xbian-package-config-shell
xbian-package-firmware
xbian-package-repo
xbian-package-xbmc
xbian-update

I have found that the problem of pvr.mythtv recordings playback happens as soon as linux-image-bcm2836 is upgraded from 4.4.48+-1486919396 to 4.9.17+-1490545026. I have also verified that the upgrade of the packages does cause the problem if linux-image-bcm2836 is not upgraded.

Best,

S

@mkreisl

This comment has been minimized.

Show comment
Hide comment
@mkreisl

mkreisl Apr 2, 2017

Contributor

@ssakatausa
Thanks for clarifying this. Now we know which package is the culprit.

I'm wondering why kernel 4.9 does not work in that case, because i'm using this version since months and never had issues, but using tvheadend and vdr vnsi pvr and not mythtv. Seems I have to reactivate my old mythv server

Contributor

mkreisl commented Apr 2, 2017

@ssakatausa
Thanks for clarifying this. Now we know which package is the culprit.

I'm wondering why kernel 4.9 does not work in that case, because i'm using this version since months and never had issues, but using tvheadend and vdr vnsi pvr and not mythtv. Seems I have to reactivate my old mythv server

@mkreisl mkreisl added the confirmed label Apr 2, 2017

@mkreisl

This comment has been minimized.

Show comment
Hide comment
@mkreisl

mkreisl Apr 2, 2017

Contributor

So, mythtv back from retirement and can confirm that Kodi/Mythtv combination on RPi(3) is very very unstable when running kernel 4.9.
Sometimes I can can play live tv and recordings and sometimes not.

Contributor

mkreisl commented Apr 2, 2017

So, mythtv back from retirement and can confirm that Kodi/Mythtv combination on RPi(3) is very very unstable when running kernel 4.9.
Sometimes I can can play live tv and recordings and sometimes not.

@mkreisl mkreisl changed the title from pvr recordings playback results in an immediate death to pvr.mythtv recordings playback results in an immediate death Apr 2, 2017

@ssakatausa

This comment has been minimized.

Show comment
Hide comment
@ssakatausa

ssakatausa Apr 2, 2017

@mkreisl
It is interesting that you can sometimes play live TV and recordings. In my experiments, Kodi instantly froze 100% times. By the way, I have found that kodi can play the recording video files on the mythtv backend server without any problems via the video menu. It is very puzzling that accessing the same file via pvr.mythtv gets kodi frozen.

ssakatausa commented Apr 2, 2017

@mkreisl
It is interesting that you can sometimes play live TV and recordings. In my experiments, Kodi instantly froze 100% times. By the way, I have found that kodi can play the recording video files on the mythtv backend server without any problems via the video menu. It is very puzzling that accessing the same file via pvr.mythtv gets kodi frozen.

@mkreisl

This comment has been minimized.

Show comment
Hide comment
@mkreisl

mkreisl Apr 3, 2017

Contributor

I tested a bit more today, kernels up to 4.8.x are working well. and all kernels from 4.9.x to 4.11.0~rc4 having same issue, seems that most kernel functions are broken. Kodi is still responding, when pressing Ok button I get timeshift bar and time is counting until a disk and/or network access will be done, then everything is stopped.

But very interesting, RPi1 is working very well with kernel 4.9.x, only RPi2&3 won't work

Contributor

mkreisl commented Apr 3, 2017

I tested a bit more today, kernels up to 4.8.x are working well. and all kernels from 4.9.x to 4.11.0~rc4 having same issue, seems that most kernel functions are broken. Kodi is still responding, when pressing Ok button I get timeshift bar and time is counting until a disk and/or network access will be done, then everything is stopped.

But very interesting, RPi1 is working very well with kernel 4.9.x, only RPi2&3 won't work

@mkreisl

This comment has been minimized.

Show comment
Hide comment
@mkreisl

mkreisl Apr 7, 2017

Contributor

@ssakatausa

Could you please turn off dynamic priority (can be done in xbian-config GUI or manually in file /etc/default/xbmc, DPRIORITY=no) and check again kernel 4.9

Using dynamic priority is culprit (not sure what happens exactly, if kernel having issue or whatever)

Contributor

mkreisl commented Apr 7, 2017

@ssakatausa

Could you please turn off dynamic priority (can be done in xbian-config GUI or manually in file /etc/default/xbmc, DPRIORITY=no) and check again kernel 4.9

Using dynamic priority is culprit (not sure what happens exactly, if kernel having issue or whatever)

@ssakatausa

This comment has been minimized.

Show comment
Hide comment
@ssakatausa

ssakatausa Apr 7, 2017

@mkreisl

Yes, turning off dynamic priority fixes the problem under kernel 4.9. But it also makes HD playback a little sluggish compared to that with dynamic priority "on" under the previous kernel.

ssakatausa commented Apr 7, 2017

@mkreisl

Yes, turning off dynamic priority fixes the problem under kernel 4.9. But it also makes HD playback a little sluggish compared to that with dynamic priority "on" under the previous kernel.

mkreisl added a commit to xbianonpi/xbian-package-xbmc-scripts that referenced this issue Apr 8, 2017

Disable dynamic priority per default
Under special condition system freezes if set to on
see issud xbianonpi/xbian#837
@mkreisl

This comment has been minimized.

Show comment
Hide comment
@mkreisl

mkreisl Apr 8, 2017

Contributor

Dynamic priority disabled per default now

But it also makes HD playback a little sluggish compared to that with dynamic priority "on" under the previous kernel

Can't see any difference here

Contributor

mkreisl commented Apr 8, 2017

Dynamic priority disabled per default now

But it also makes HD playback a little sluggish compared to that with dynamic priority "on" under the previous kernel

Can't see any difference here

@mkreisl mkreisl added the fixed label Apr 8, 2017

@mkreisl

This comment has been minimized.

Show comment
Hide comment
@mkreisl

mkreisl Apr 8, 2017

Contributor

Btw, running kernel 4.10.8 on my i.MX6 Hummingboard now.
Will test if this issue occurs when enabling dynamic priority

Contributor

mkreisl commented Apr 8, 2017

Btw, running kernel 4.10.8 on my i.MX6 Hummingboard now.
Will test if this issue occurs when enabling dynamic priority

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment