Permalink
Browse files

changed, always show video->files so we do not have to add a video so…

…urce to see usb drives
  • Loading branch information...
1 parent 2fdc4df commit 99be81489bd39c545119aeb7b4c155dd3965c0cb @davilla davilla committed Apr 23, 2012
Showing with 1 addition and 11 deletions.
  1. +1 −1 xbmc/filesystem/SourcesDirectory.cpp
  2. +0 −10 xbmc/video/GUIViewStateVideo.cpp
@@ -53,7 +53,7 @@ bool CSourcesDirectory::GetDirectory(const CStdString& strPath, CFileItemList &i
sources = *sourcesFromType;
g_mediaManager.GetRemovableDrives(sources);
- if (sources.empty())
+ if (!sourcesFromType)
return false;
return GetDirectory(sources, items);
@@ -423,16 +423,6 @@ VECSOURCES& CGUIViewStateWindowVideoNav::GetSources()
m_sources.push_back(share);
}
- if (g_settings.GetSourcesFromType("video")->empty())
- { // no sources - add the "Add Source" item
- CMediaSource share;
- share.strName=g_localizeStrings.Get(999); // "Add Videos"
- share.strPath = "sources://add/";
- share.m_strThumbnailImage = CUtil::GetDefaultFolderThumb("DefaultAddSource.png");
- share.m_iDriveType = CMediaSource::SOURCE_TYPE_LOCAL;
- m_sources.push_back(share);
- }
- else
{
{ // Files share
CMediaSource share;

4 comments on commit 99be814

Owner

Memphiz replied May 7, 2012

Mhh could this be related to the fact that on a fresh install the "add sources" option is not visible in files? I experienced this and at least one user in the forum too. Will trigger jezz on this too...

Owner

Montellese replied May 7, 2012

It's probably the library customization changes from @jmarshallnz which causes that problem. And it has been confirmed by me and several other team members that the problem exists on all fresh installs.

Owner

Memphiz replied May 7, 2012

Ahh ok - thx :)

Member

jmarshallnz replied May 7, 2012

  1. It was fixed yesterday.
  2. It wasn't caused by me, rather by the tinyxml merge. :p
Please sign in to comment.