Skip to content
Browse files

[osx/docs] - update README.osx - we support building with Xcode 5.1.1…

… on Mavericks 10.9.x against SDK 10.8 and 10.9
  • Loading branch information...
1 parent 06959f1 commit bbf6fcb52eb127869066ae532ffe1c504532d1c3 @Memphiz Memphiz committed Jun 19, 2014
Showing with 9 additions and 5 deletions.
  1. +9 −5 docs/README.osx
View
14 docs/README.osx
@@ -14,7 +14,7 @@ TOC
-----------------------------------------------------------------------------
This is a platform port of XBMC for the Apple OSX operating system. 10.6, 10.7
-and 10.8 Intel development platforms are supported. Xcode 3.2.6 and 4.3 and newer
+10.8 and 10.9 Intel development platforms are supported. Xcode 3.2.6 and 4.3 and newer
are the recommended versions.
There are 3 ways to build XBMC for Mac, from command-line with make, from command-line
using xcodebuild or from Xcode.
@@ -28,12 +28,13 @@ codecs that support a multitude of music and video formats.
On Snow Leopard (OSX 10.6.x) we recommend using Xcode 3.2.6.
On Lion (OSX 10.7.x) we recommend using Xcode 4.3.x.
On Mountain Lion (OSX 10.8.1) we recommend using Xcode 4.4.
+On Mavericks (OSX 10.9.3) we recommend using Xcode 5.1.1.
NOTE TO NEW OS X USERS: All lines that are prefixed with the '$' character are
commands that need to be typed into a Terminal window. Note that the '$'
character itself should NOT be typed as part of the command.
-ATTENTION: When using Mountain Lion (OSX 10.8.x) you need to download and install
+ATTENTION: When using Mountain Lion (OSX 10.8.x) or Mavericks (10.9.x) you need to download and install
XQuartz from https://xquartz.macosforge.org/landing/ since its not part of OSX
anymore.
@@ -49,18 +50,20 @@ anymore.
-----------------------------------------------------------------------------
See point 3.0a below for an updated list of supported/tested Xcode/osx constellations!!!
-Install latest Xcode (4.3.2 or 3.2.6 as of the writing). You can download it from
+Install latest Xcode (5.1.1 or 3.2.6 as of the writing). You can download it from
1. Apple's site after registration at http://developer.apple.com/tools/download (Xcode 3.2.6)
-2. In the MacOSX AppStore (Xcode 4.3.x).
+2. In the MacOSX AppStore (Xcode 4.3.x and later).
If you are using XCode 4.3.x or later you also need to install the "Command Line Tools". To do so
after installing Xcode you have to go to "Xcode->Preferences->Downloads" and install the
-package "Command Line Tools".
+package "Command Line Tools". This is not needed anymore in Xcode 5.x. Command Line Tools are installed
+automagically on first invoke.
Xcode 3.2.6 only runs on 10.6.x (Snow Leopard).
Xcode 4.3.x only runs on 10.7.x (Lion).
Xcode 4.4 only runs on 10.8.x (Mountain Lion).
+Xcode 5.1.1 runs on 10.8.x and 10.9.x (Mavericks).
-----------------------------------------------------------------------------
3.0a Supported Xcode and OSX constellations
@@ -71,6 +74,7 @@ constellations of Xcode and osx versions (to be updated once we know more):
1. XCode 3.2.6 against OSX SDK 10.6 on 10.6.x (Snow Leopard)
2. XCode 4.3.x against OSX SDK 10.6 and 10.7 on 10.7.x (Lion)
3. XCode 4.6 against OSX SDK 10.6, 10.7 and 10.8 on 10.7.x (Lion) and 10.8.x (ML)
+4. XCode 5.1.1 against OSX SDK 1.8 (ML) and 10.9 (M)
-----------------------------------------------------------------------------
3.1 Install XBMC build depends

0 comments on commit bbf6fcb

Please sign in to comment.
Something went wrong with that request. Please try again.