Skip to content
This repository
Browse code

removed: dependency on libfaac which doesn't seem to be used anywhere

git-svn-id: https://xbmc.svn.sourceforge.net/svnroot/xbmc/trunk@35279 568bbfeb-2a22-0410-94d2-cc84cf5bfa90
  • Loading branch information...
commit db9c50c812aa7dd6b29c2021ae04be089f10ab1b 1 parent f619c63
authored November 15, 2010
3  README.armel
@@ -212,13 +212,12 @@ It is also assumed that you have it setup with either Angstrom or Ubuntu.
212 212
 	-----------------------------------------------------------------------------
213 213
 
214 214
 	For Ubuntu: See README.linux for list of packages to install.
215  
-	The known packages not to work are: libfaac-dev (use libfaad-dev instead)
216 215
 	If planning on not extracting the pkgs file, a few additional packages are required to be installed.
217 216
 	These are python and liblzo2
218 217
 
219 218
 	For Angstrom:
220 219
 		# opkg update
221  
-		# opkg install subversion make g++ gcc gawk pmount libtool automake gperf unzip bison libsdl-1.2-dev libsdl-image-1.2-dev libsdl-gfx-dev libsdl-mixer-1.2-dev libfribidi-dev liblzo-dev libfreetype-dev libsqlite3-dev libasound2 python-sqlite3 libcurl4 libxrandr-dev libxrender-dev libmad-dev libogg-dev libvorbis-dev libmysqlclient-dev libpcre-dev libdbus-glib-1-dev hal-dev libjasper-dev libfontconfig-dev boost-dev libfaac-dev libxt-dev libxmu-dev libpng-dev libjpeg-dev libsamplerate0-dev
  220
+		# opkg install subversion make g++ gcc gawk pmount libtool automake gperf unzip bison libsdl-1.2-dev libsdl-image-1.2-dev libsdl-gfx-dev libsdl-mixer-1.2-dev libfribidi-dev liblzo-dev libfreetype-dev libsqlite3-dev libasound2 python-sqlite3 libcurl4 libxrandr-dev libxrender-dev libmad-dev libogg-dev libvorbis-dev libmysqlclient-dev libpcre-dev libdbus-glib-1-dev hal-dev libjasper-dev libfontconfig-dev boost-dev libxt-dev libxmu-dev libpng-dev libjpeg-dev libsamplerate0-dev
222 221
 	
223 222
 	Unfortunately this will only install the packages that are available through opkg. There will be further packages that need to be installed.
224 223
 	Either use the method mentioned below, or selectively find and install packages, mentioned at the bottom of this README.
2  README.linux
@@ -53,7 +53,7 @@ Build-Depends: debhelper (>= 7.0.50~), python-support, cmake,
53 53
  libwavpack-dev, python-dev, gawk, gperf, nasm [!amd64], libcwiid1-dev,
54 54
  libbluetooth-dev, zlib1g-dev, libmms-dev (>= 0.4), libsmbclient-dev,
55 55
  libfaad-dev, libiso9660-dev, libssl-dev, lsb-release, libvdpau-dev, libmicrohttpd-dev,
56  
- libmodplug-dev, librtmp-dev, libcrystalhd-dev, curl, libfaac-dev
  56
+ libmodplug-dev, librtmp-dev, libcrystalhd-dev, curl
57 57
 
58 58
 *** For developers and anyone else who compiles frequently it is recommended to
59 59
 use ccache
2  README.ubuntu
@@ -44,7 +44,7 @@ Two methods exist to install the required Ubuntu packages:
44 44
 
45 45
 For Ubuntu (all versions >= 7.04):
46 46
 
47  
-   # sudo apt-get install subversion make g++ gcc gawk pmount libtool nasm yasm automake cmake gperf zip unzip bison libsdl-dev libsdl-image1.2-dev libsdl-gfx1.2-dev libsdl-mixer1.2-dev libfribidi-dev liblzo2-dev libfreetype6-dev libsqlite3-dev libogg-dev libasound-dev python-sqlite libglew-dev libcurl3 libcurl4-gnutls-dev libxrandr-dev libxrender-dev libmad0-dev libogg-dev libvorbisenc2 libsmbclient-dev libmysqlclient-dev libpcre3-dev libdbus-1-dev libhal-dev libhal-storage-dev libjasper-dev libfontconfig-dev libbz2-dev libboost-dev libfaac-dev libenca-dev libxt-dev libxtst-dev libxmu-dev libpng-dev libjpeg-dev libpulse-dev mesa-utils libcdio-dev libsamplerate-dev libmms-dev libmpeg3-dev libfaad-dev libflac-dev libiso9660-dev libass-dev libssl-dev fp-compiler gdc libwavpack-dev libmpeg2-4-dev libmicrohttpd-dev libmodplug-dev libssh-dev gettext cvs
  47
+   # sudo apt-get install subversion make g++ gcc gawk pmount libtool nasm yasm automake cmake gperf zip unzip bison libsdl-dev libsdl-image1.2-dev libsdl-gfx1.2-dev libsdl-mixer1.2-dev libfribidi-dev liblzo2-dev libfreetype6-dev libsqlite3-dev libogg-dev libasound-dev python-sqlite libglew-dev libcurl3 libcurl4-gnutls-dev libxrandr-dev libxrender-dev libmad0-dev libogg-dev libvorbisenc2 libsmbclient-dev libmysqlclient-dev libpcre3-dev libdbus-1-dev libhal-dev libhal-storage-dev libjasper-dev libfontconfig-dev libbz2-dev libboost-dev libenca-dev libxt-dev libxtst-dev libxmu-dev libpng-dev libjpeg-dev libpulse-dev mesa-utils libcdio-dev libsamplerate-dev libmms-dev libmpeg3-dev libfaad-dev libflac-dev libiso9660-dev libass-dev libssl-dev fp-compiler gdc libwavpack-dev libmpeg2-4-dev libmicrohttpd-dev libmodplug-dev libssh-dev gettext cvs
48 48
 
49 49
 For Ubuntu Maverick (10.10):
50 50
    # sudo apt-get install autopoint
27  configure.in
@@ -48,8 +48,6 @@ goom_enabled="== GOOM enabled. =="
48 48
 goom_disabled="== GOOM disabled. =="
49 49
 pulse_not_found="== Could not find libpulse. PulseAudio support disabled. =="
50 50
 pulse_disabled="== PulseAudio support manually disabled. =="
51  
-faac_not_found="== Could not find libfaac. FAAC support disabled. =="
52  
-faac_disabled="== FAAC support manually disabled. =="
53 51
 dvdcss_enabled="== DVDCSS support enabled. =="
54 52
 dvdcss_disabled="== DVDCSS support disabled. =="
55 53
 hal_not_found="== Could not find hal. HAL support disabled. =="
@@ -209,12 +207,6 @@ AC_ARG_ENABLE([ffmpeg_libvorbis],
209 207
   [use_ffmpeg_libvorbis=$enableval],
210 208
   [use_ffmpeg_libvorbis=no])
211 209
 
212  
-AC_ARG_ENABLE([faac],
213  
-  [AS_HELP_STRING([--enable-faac],
214  
-  [enable FAAC support (default is yes)])],
215  
-  [use_faac=$enableval],
216  
-  [use_faac=yes])
217  
-
218 210
 AC_ARG_ENABLE([dvdcss],
219 211
   [AS_HELP_STRING([--enable-dvdcss],
220 212
   [enable DVDCSS support (default is yes)])],
@@ -713,19 +705,6 @@ else
713 705
   AC_MSG_RESULT($pulse_disabled)
714 706
 fi
715 707
 
716  
-# FAAC
717  
-if test "$host_vendor" = "apple" ; then
718  
-  use_faac="no"
719  
-  AC_MSG_RESULT($faac_disabled)
720  
-else
721  
-  if test "$use_faac" = "yes"; then
722  
-    AC_CHECK_LIB([faac], [main],,
723  
-      use_faac=no;AC_MSG_RESULT($faac_not_found))
724  
-  else
725  
-    AC_MSG_RESULT($faac_disabled)
726  
-  fi
727  
-fi
728  
-
729 708
 # HAL
730 709
 if test "$host_vendor" = "apple" ; then
731 710
   use_hal="no"
@@ -1236,12 +1215,6 @@ else
1236 1215
   final_message="$final_message\n  HAL Support:\tNo"
1237 1216
 fi
1238 1217
 
1239  
-if test "$use_faac" = "yes"; then
1240  
-  final_message="$final_message\n  FAAC:\t\tYes"
1241  
-else
1242  
-  final_message="$final_message\n  FAAC:\t\tNo"
1243  
-fi
1244  
-
1245 1218
 # DVDCSS
1246 1219
 if test "$use_dvdcss" = "yes"; then
1247 1220
   AC_MSG_NOTICE($dvdcss_enabled)
2  tools/Linux/packaging/debian/rules
@@ -26,7 +26,7 @@ endif
26 26
 
27 27
 # Ubuntu or Debian specific options
28 28
 ifeq (Ubuntu,$(shell lsb_release -is))
29  
-  DISTRO_SPECIFIC_OPTIONS = --enable-faac
  29
+  DISTRO_SPECIFIC_OPTIONS = 
30 30
 else
31 31
   DISTRO_SPECIFIC_OPTIONS = --enable-external-libraries --disable-dvdcss \
32 32
     --disable-non-free
4  tools/Linux/packaging/debian/var_info
@@ -20,10 +20,6 @@ BUILD_DEPENDS="debhelper (>= 7.0.50~), python-support, cmake,
20 20
  libfaad-dev, libiso9660-dev, libssl-dev, lsb-release, libvdpau-dev, libmicrohttpd-dev,
21 21
  libmodplug-dev, librtmp-dev, libcrystalhd-dev, curl,"
22 22
 
23  
-if [ $(lsb_release -is) = "Ubuntu" ]; then
24  
-    BUILD_DEPENDS="$BUILD_DEPENDS libfaac-dev,"
25  
-fi
26  
-
27 23
 case "$1" in
28 24
     BUILD_DEPENDS)
29 25
         printf "$BUILD_DEPENDS"
2  xbmc/cores/dvdplayer/Codecs/ffmpeg/build_xbmc.sh
@@ -13,7 +13,7 @@ echo wrapping libavutil
13 13
 gcc -shared -fPIC --soname,avutil-51-i486-linux.so -o avutil-51-i486-linux.so -rdynamic libavutil/*.o 
14 14
 
15 15
 echo wrapping libavcodec
16  
-gcc -o avcodec-51-i486-linux.so --soname,avcodec-51-i486-linux.so -shared -fPIC -rdynamic /usr/lib/libfaac.a  libavcodec/*.o libavcodec/i386/*.o `cat $XBMC_ROOT/xbmc/cores/DllLoader/exports/wrapper.def` $XBMC_ROOT/xbmc/cores/DllLoader/exports/wrapper.o
  16
+gcc -o avcodec-51-i486-linux.so --soname,avcodec-51-i486-linux.so -shared -fPIC -rdynamic libavcodec/*.o libavcodec/i386/*.o `cat $XBMC_ROOT/xbmc/cores/DllLoader/exports/wrapper.def` $XBMC_ROOT/xbmc/cores/DllLoader/exports/wrapper.o
17 17
 
18 18
 echo wrapping libavformat
19 19
 gcc -o avformat-51-i486-linux.so --soname,avformat-51-i486-linux.so -shared  -fPIC  -rdynamic libavformat/*.o `cat $XBMC_ROOT/xbmc/cores/DllLoader/exports/wrapper.def`,-export-all-symbols $XBMC_ROOT/xbmc/cores/DllLoader/exports/wrapper.o

0 notes on commit db9c50c

Please sign in to comment.
Something went wrong with that request. Please try again.