Skip to content
This repository
Browse code

[depends] - fix target config site script. It wants to set LD_LIBRARY…

…_PATH to the deps dir not to the native buildtools. Found when trying to get ffmpeg gnutls to work. On osx ffmpeg tried to pull in libz from native dir instead of system toolchain because ld_library_path was set wrong
  • Loading branch information...
commit f02e456f996cc44a18e15c95e53bfa9471e40a7c 1 parent 2466561
Memphiz authored September 09, 2013

Showing 1 changed file with 1 addition and 1 deletion. Show diff stats Hide diff stats

  1. 2  tools/depends/target/config.site.in
2  tools/depends/target/config.site.in
@@ -32,7 +32,7 @@ export NASM=@prefix@/@tool_dir@/bin/yasm
32 32
 export MYSQL_CONFIG=@prefix@/@deps_dir@/bin/mysql_config
33 33
 
34 34
 PATH=@prefix@/@tool_dir@/bin:@use_toolchain@/usr/bin:@use_toolchain@/bin:$PATH
35  
-LD_LIBRARY_PATH=@prefix@/@tool_dir@/lib:$LD_LIBRARY_PATH
  35
+LD_LIBRARY_PATH=@prefix@/@deps_dir@/lib:$LD_LIBRARY_PATH
36 36
 
37 37
 PYTHON_VERSION=2.6
38 38
 PYTHON_LDFLAGS="-L@prefix@/@deps_dir@/lib -lpython${PYTHON_VERSION} -lc -ldl -lm -lexpat -lffi -lintl -lutil -lssl -lcrypto"

0 notes on commit f02e456

Please sign in to comment.
Something went wrong with that request. Please try again.