Permalink
Browse files

[osx] fixed default sdk selector when compiling on 10.8 and force to …

…10.7 sdk
  • Loading branch information...
davilla committed Aug 10, 2012
1 parent 4b9491d commit f835fb5b9984875ebefe5dd44bef2aa3362fea0b
Showing with 5 additions and 2 deletions.
  1. +5 −2 tools/darwin/depends/configure.in
@@ -36,10 +36,13 @@ case $use_darwin in
if test "$use_arch" = "armv7"; then
AC_MSG_ERROR(error in configure of --with-arch=$use_arch)
fi
- found_sdk_version=[`$use_xcodebuild -showsdks | grep macosx | sort | tail -n 1 | awk '{ print $4}'`]
+ found_sdk_version=[`$use_xcodebuild -showsdks | grep macosx | sort | tail -n 1 | grep -oE 'macosx[0-9.0-9]+' | cut -c 7-$NF`]
use_sdk="${use_sdk:-$found_sdk_version}"
case $use_sdk in
- 10.*);;
+ 10.5);;
+ 10.6);;
+ 10.7);;
+ 10.8) use_sdk=10.7;;
*)
AC_MSG_ERROR(error in configure of --with-sdk=$use_sdk)
esac

0 comments on commit f835fb5

Please sign in to comment.