Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[cmake] Fix XPREFIX_LIBRARIES populating in modules #11161

Merged
merged 1 commit into from Dec 14, 2016

Conversation

@hudokkow
Copy link
Member

commented Dec 13, 2016

Description

Fixes unneeded "-l" when setting libraries.

Motivation and Context

Fix http://forum.kodi.tv/showthread.php?tid=255893&pid=2477415#pid2477415 and conform to https://cmake.org/cmake/help/v3.1/module/FindPkgConfig.html

How Has This Been Tested?

Not at all.

Screenshots (if appropriate):

Types of change

  • Bug fix (non-breaking change which fixes an issue)
@wsnipex
Copy link
Member

left a comment

thanks, lgtm

@wsnipex

This comment has been minimized.

Copy link
Member

commented Dec 13, 2016

jenkins build this please

@MartijnKaijser

This comment has been minimized.

Copy link
Member

commented Dec 13, 2016

Jenkins build this please

@wsnipex wsnipex merged commit 09c2842 into xbmc:master Dec 14, 2016

3 checks passed

continuous-integration/appveyor/pr AppVeyor build succeeded
Details
continuous-integration/travis-ci/pr The Travis CI build passed
Details
jenkins4kodi You did a great job. Have a cookie.
Details

@hudokkow hudokkow added this to the L 18.0-alpha1 milestone Dec 14, 2016

@hudokkow hudokkow deleted the hudokkow:cmake_fix_libs branch Dec 14, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.