Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[cmake] FindBluray.cmake: fix version check #12562

Merged
merged 1 commit into from Jul 25, 2017

Conversation

@wsnipex
Copy link
Member

commented Jul 24, 2017

properly check libbluray version

Description

Motivation and Context

reported by @notspiff
currently the version check is only done using pkg-config. If pkg-config fails (e.g. because of too low version), we still do the manual search without any further version checks.
The effect is that libbluray <=0.9.2 is accepted, even though the find rule tries to enforce 0.9.3

How Has This Been Tested?

not really

Screenshots (if appropriate):

Types of change

  • Bug fix (non-breaking change which fixes an issue)
  • Improvement (non-breaking change which improves existing functionality)
  • New feature (non-breaking change which adds functionality)
  • Breaking change (fix or feature that would cause existing functionality to change)

@wsnipex wsnipex requested a review from hudokkow Jul 24, 2017

@notspiff

This comment has been minimized.

Copy link
Contributor

commented Jul 24, 2017

ack.

@hudokkow

This comment has been minimized.

Copy link
Member

commented Jul 25, 2017

lgtm. thx to both!

@MartijnKaijser MartijnKaijser added this to the L 18.0-alpha1 milestone Jul 25, 2017

@MartijnKaijser MartijnKaijser merged commit 3370802 into xbmc:master Jul 25, 2017

1 check passed

default You're awesome. Have a cookie
Details
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
5 participants
You can’t perform that action at this time.