XCAT_2.9.3_Release_Notes

Xiaopeng Wang edited this page Mar 11, 2016 · 14 revisions

News

History

  • Oct 22, 2010: xCAT 2.5 released.
  • Apr 30, 2010: xCAT 2.4 is released.
  • Oct 31, 2009: xCAT 2.3 released. xCAT's 10 year anniversary!
  • Apr 16, 2009: xCAT 2.2 released.
  • Oct 31, 2008: xCAT 2.1 released.
  • Sep 12, 2008: Support for xCAT 2 can now be purchased!
  • June 9, 2008: xCAT breaths life into (at the time) the fastest supercomputer on the planet
  • May 30, 2008: xCAT 2.0 for Linux officially released!
  • Oct 31, 2007: IBM open sources xCAT 2.0 to allow collaboration among all of the xCAT users.
  • Oct 31, 1999: xCAT 1.0 is born!
    xCAT started out as a project in IBM developed by Egan Ford. It was quickly adopted by customers and IBM manufacturing sites to rapidly deploy clusters.
Clone this wiki locally

xCAT 2.9.3 is ONLY released for AIX

New Functions and Changes in Behavior

  • New Operating System Support

    • AIX 7.2.0, AIX 7.1.4.1

      Diskfull Install

      Verified updatenode command

      Verified syncfile mechanism

  • New Features

    • Support the new format 'file -> (noderange for permitted nodes) file' in synclist file for file syncing. With this feature you can specify which nodes this entry applies for.

Test Environment

xCAT core packages tar ball:

xCAT dependency package verified with this xCAT release:

The following xCAT dependency packages were built against AIX 7.2

  • perl-DBD-SQLite ver 1.48
  • perl-DBI ver 1.634
  • perl-Debug-Trace ver 0.05
  • perl-Digest-HMAC ver 1.03
  • perl-Digest-MD5 ver 2.54
  • perl-Digest-SHA ver 5.95
  • perl-Digest-SHA1 ver 2.13
  • perl-Socket-SSL ver 1.38
  • perl-IO-Tty ver 1.12
  • perl-Net-DNS ver 1.04
  • perl-Net-IP ver 1.26
  • perl-Net-Telnet ver 3.04
  • perl-XML-Simple ver 2.22
  • net-snmp ver 5.7.3
  • cURL ver 7.46.0

Only SQLite is supported on AIX 7.2. MySQL and PostgreSQL is not supported on AIX 7.2.

Operating Systems which have been verified:

AIX6.1 TL8 SP6
AIX6.1 TL9 SP5
AIX7.1 TL4 SP1
AIX7.2 

Hardware Platform which have been verified:

POWER 7
POWER8 BE (HMC version: V8R8.3.0)

Issues Fixed

The following key Issues are resolved for this release and highlighted below:

  • Issue #573: xcatd displays error message when performing restart. Restart of xcatd causes core dump on AIX.

  • Issue #569: Update of xCAT will overwrite values in site.xcatsslversion.

Full list of Resolved Issues

Restrictions and Known Problems

  • Issue #691: xCAT migration from 2.9.2 on aix71R to 2.9.3 on aix720 failed

    When updating both xCAT 2.9.2 => xCAT 2.9.3 and AIX 7.1 => AIX 7.2, use the following procedure as a reference:

    1. Update AIX 7.1 to AIX 7.2 first
    2. Remove the incorrect rpm packages installed for AIX 7.1

      rpm -e perl-Expect-1.21-3 perl-Digest-SHA-5.48-3 \
      perl-IO-Stty-0.03-2 net-snmp-5.7.2-3 \
      net-snmp-devel-5.7.2-3 net-snmp-perl-5.7.2-3 \ 
      perl-version-0.82-2 perl-Crypt-SSLeay
      
    3. Install xCAT dependency packages

      ./instoss
      
    4. If you get the message ln: 0653-421 /lib/libperl.a exists. Specify -f to remove /lib/libperl.a before linking. during the update of xcat-dep, remove the sybolic link /lib/libperl.a.

      rm /lib/libperl.a
      
    5. Install xCAT

      ./instxcat