Permalink
Browse files

Update package.json to use more explicit version numbers

The old version specifiers allowed npm to install any version greater
than the given version. Unfortunately this also includes beta-versions
which could include API changes against which cm-update-server was not
tested yet.
Thus update the version numbers so npm stays within the configured
major version, but still allows updating to different minor or bugfix
versions without package.json changes.
  • Loading branch information...
1 parent da98b6d commit 467cc2330103b1e01b8884ce48b9a43e2080004c @xdarklight committed Nov 12, 2016
Showing with 12 additions and 12 deletions.
  1. +12 −12 package.json
View
@@ -12,20 +12,20 @@
},
"dependencies": {
- "troll-opt" : ">= 0.7.x",
- "config": ">= 0.4.x",
- "restify": ">= 3.0.x",
- "sequelize-cli": ">= 2.0.0",
- "sequelize": ">= 3.23.6"
+ "troll-opt" : "^0.7.0",
+ "config": "^1.24.0",
+ "restify": "^4.2.0",
+ "sequelize-cli": "^2.4.0",
+ "sequelize": "^3.23.6"
},
"optionalDependencies": {
- "sqlite3": ">= 3.0.5",
- "mysql": ">= 2.x",
- "mariasql": ">= 0.1.x",
- "wintersmith": ">= 2.1.x",
- "fs-extra": ">= 0.10.0",
- "filesize": ">= 2.0.0",
- "async": ">= 0.9.0"
+ "sqlite3": "^3.0.5",
+ "mysql": "^2.0.0",
+ "mariasql": "^0.2.0",
+ "wintersmith": "^2.3.0",
+ "fs-extra": "^1.0.0",
+ "filesize": "^3.3.0",
+ "async": "^2.0.0"
}
}

0 comments on commit 467cc23

Please sign in to comment.