Skip to content
Permalink
Browse files

Make config.m4 warn about anything < 7.0 and >= 7.3

  • Loading branch information...
derickr committed Dec 14, 2016
1 parent 890707c commit 9bda2b3fc0ea833eed8b9526655170769d0eeb60
Showing with 4 additions and 4 deletions.
  1. +4 −4 config.m4
@@ -8,11 +8,11 @@ if test "$PHP_XDEBUG" != "no"; then
AC_MSG_CHECKING([Check for supported PHP versions])
PHP_XDEBUG_FOUND_VERSION=`${PHP_CONFIG} --version`
PHP_XDEBUG_FOUND_VERNUM=`echo "${PHP_XDEBUG_FOUND_VERSION}" | $AWK 'BEGIN { FS = "."; } { printf "%d", ([$]1 * 100 + [$]2) * 100 + [$]3;}'`
if test "$PHP_XDEBUG_FOUND_VERNUM" -lt "50500"; then
AC_MSG_ERROR([not supported. Need a PHP version >= 5.5.0 and < 7.2.0 (found $PHP_XDEBUG_FOUND_VERSION)])
if test "$PHP_XDEBUG_FOUND_VERNUM" -lt "70000"; then
AC_MSG_ERROR([not supported. Need a PHP version >= 7.0.0 and < 7.3.0 (found $PHP_XDEBUG_FOUND_VERSION)])
else
if test "$PHP_XDEBUG_FOUND_VERNUM" -ge "70200"; then
AC_MSG_ERROR([not supported. Need a PHP version >= 5.5.0 and < 7.2.0 (found $PHP_XDEBUG_FOUND_VERSION)])
if test "$PHP_XDEBUG_FOUND_VERNUM" -ge "70300"; then
AC_MSG_ERROR([not supported. Need a PHP version >= 7.0.0 and < 7.3.0 (found $PHP_XDEBUG_FOUND_VERSION)])
else
AC_MSG_RESULT([supported ($PHP_XDEBUG_FOUND_VERSION)])
fi

0 comments on commit 9bda2b3

Please sign in to comment.
You can’t perform that action at this time.