Bad URL for Oracle VM VirtualBox Extension Pack when using distro provided virtualbox package (ubuntu) #46

Closed
gsgleason opened this Issue Nov 10, 2011 · 6 comments

Comments

Projects
None yet
7 participants
@gsgleason

Here is what I get when I try to run script:

$ IEVMS_VERSIONS="9" bash ievms.sh
Checking for VirtualBox
Checking for Oracle VM VirtualBox Extension Pack
Installing Oracle VM VirtualBox Extension Pack from /home/gsg/.ievms/Oracle_VM_VirtualBox_Extension_Pack-4.1.2_Ubuntu-38459.vbox-extpack
VBoxManage: error: RTZipGzipDecompressIoStream failed: VERR_ZIP_BAD_HEADER
VBoxManage: error: Details: code NS_ERROR_FAILURE (0x80004005), component ExtPackFile, interface IExtPackFile, callee nsISupports
Context: "Install(fReplace, NULL, ptrProgress.asOutParam())" at line 1083 of file VBoxManageMisc.cpp

ERROR: Failed to install Oracle VM VirtualBox Extension Pack from /home/gsg/.ievms/Oracle_VM_VirtualBox_Extension_Pack-4.1.2_Ubuntu-38459.vbox-extpack, error code (0)

'VBoxManage -v' gives: 4.1.2_Ubuntur38459

It tries to download the following, which fails:

http://download.virtualbox.org/virtualbox/4.1.2_Ubuntu/Oracle_VM_VirtualBox_Extension_Pack-4.1.2_Ubuntu-38459.vbox-extpack

This doesn't happen with the package directly from virtualbox.org.

I'm not sure if you want to enhance the parsing for the version to deal with provider specific version strings, but there you go.

@blackrobot

This comment has been minimized.

Show comment Hide comment
@blackrobot

blackrobot Nov 10, 2011

A temporary fix is to download, an manually install the package:

  1. wget http://download.virtualbox.org/virtualbox/4.1.6/Oracle_VM_VirtualBox_Extension_Pack-4.1.6-74713.vbox-extpack
  2. VBoxManage extpack install Oracle_VM_VirtualBox_Extension_Pack-4.1.6-74713.vbox-extpack
  3. sudo apt-get install rar unrar
  4. Then, just run the script as normal: ./ievms.sh

A temporary fix is to download, an manually install the package:

  1. wget http://download.virtualbox.org/virtualbox/4.1.6/Oracle_VM_VirtualBox_Extension_Pack-4.1.6-74713.vbox-extpack
  2. VBoxManage extpack install Oracle_VM_VirtualBox_Extension_Pack-4.1.6-74713.vbox-extpack
  3. sudo apt-get install rar unrar
  4. Then, just run the script as normal: ./ievms.sh
@edrex

This comment has been minimized.

Show comment Hide comment
@edrex

edrex Mar 1, 2012

confirmed on Ubuntu 11.10

edrex commented Mar 1, 2012

confirmed on Ubuntu 11.10

@beefsack

This comment has been minimized.

Show comment Hide comment
@beefsack

beefsack Mar 28, 2012

Confirmed on Kubuntu 12.04 beta, workaround by @blackrobot works.

Confirmed on Kubuntu 12.04 beta, workaround by @blackrobot works.

@jackiekazil

This comment has been minimized.

Show comment Hide comment
@jackiekazil

jackiekazil May 25, 2012

So, I had this problem, which brought me here. I tried to go through the manual steps, but when I tried step two, I got the following...

VBoxManage: error:   Referenced from: /Applications/VirtualBox.app/Contents/MacOS/ExtensionPacks/Oracle_VM_VirtualBox_Extension_Pack/darwin.x86/VBoxPuelMain.dylib
VBoxManage: error:   Reason: Incompatible library version: VBoxPuelMain.dylib requires version 4.1.6 or later, but VBoxVMM.dylib provides version 4.0.10

Then I updated VirtualBox from 4.0.10 to 4.1.6.
After that I tried to run the original script and it worked.
I don't know if this fixes the issue. However, I hope that it helps someone somewhere.

I am using OX 10.6

So, I had this problem, which brought me here. I tried to go through the manual steps, but when I tried step two, I got the following...

VBoxManage: error:   Referenced from: /Applications/VirtualBox.app/Contents/MacOS/ExtensionPacks/Oracle_VM_VirtualBox_Extension_Pack/darwin.x86/VBoxPuelMain.dylib
VBoxManage: error:   Reason: Incompatible library version: VBoxPuelMain.dylib requires version 4.1.6 or later, but VBoxVMM.dylib provides version 4.0.10

Then I updated VirtualBox from 4.0.10 to 4.1.6.
After that I tried to run the original script and it worked.
I don't know if this fixes the issue. However, I hope that it helps someone somewhere.

I am using OX 10.6

@xdissent

This comment has been minimized.

Show comment Hide comment
@xdissent

xdissent Jun 1, 2012

Owner

Trying to figure out these linux version strings for the extension pack. Hang in there.

Owner

xdissent commented Jun 1, 2012

Trying to figure out these linux version strings for the extension pack. Hang in there.

@jsh2134

This comment has been minimized.

Show comment Hide comment
@jsh2134

jsh2134 Jul 30, 2012

Just to chime in and provide bug report:

Had the same issue with Fedora 17. I downloaded VirtualBox from RPMFusion

jhull@~ $ ./ievms.sh 
Checking for VirtualBox
Checking for Oracle VM VirtualBox Extension Pack
4.1.18_RPMFusion-78361 (output of VBoxManage -v after replacing "r" with "-")
4.1.18_RPMFusion
Downloading Oracle VM VirtualBox Extension Pack from http://download.virtualbox.org/virtualbox/4.1.18_RPMFusion/Oracle_VM_VirtualBox_Extension_Pack-4.1.18_RPMFusion-78361.vbox-extpack to /home/jhull/.ievms/Oracle_VM_VirtualBox_Extension_Pack-4.1.18_RPMFusion-78361.vbox-extpack
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
100   292  100   292    0     0    260      0  0:00:01  0:00:01 --:--:--   260
Installing Oracle VM VirtualBox Extension Pack from /home/jhull/.ievms/Oracle_VM_VirtualBox_Extension_Pack-4.1.18_RPMFusion-78361.vbox-extpack
VBoxManage: error: RTZipGzipDecompressIoStream failed: VERR_ZIP_BAD_HEADER
VBoxManage: error: Details: code NS_ERROR_FAILURE (0x80004005), component ExtPackFile, interface IExtPackFile, callee nsISupports
Context: "Install(fReplace, NULL, ptrProgress.asOutParam())" at line 1083 of file VBoxManageMisc.cpp

ERROR: Failed to install Oracle VM VirtualBox Extension Pack from /home/jhull/.ievms/Oracle_VM_VirtualBox_Extension_Pack-4.1.18_RPMFusion-78361.vbox-extpack, error code (0)

......then fails

Once I remove the "RPMFusion" bit from the version getting string everything works fine.

jsh2134 commented Jul 30, 2012

Just to chime in and provide bug report:

Had the same issue with Fedora 17. I downloaded VirtualBox from RPMFusion

jhull@~ $ ./ievms.sh 
Checking for VirtualBox
Checking for Oracle VM VirtualBox Extension Pack
4.1.18_RPMFusion-78361 (output of VBoxManage -v after replacing "r" with "-")
4.1.18_RPMFusion
Downloading Oracle VM VirtualBox Extension Pack from http://download.virtualbox.org/virtualbox/4.1.18_RPMFusion/Oracle_VM_VirtualBox_Extension_Pack-4.1.18_RPMFusion-78361.vbox-extpack to /home/jhull/.ievms/Oracle_VM_VirtualBox_Extension_Pack-4.1.18_RPMFusion-78361.vbox-extpack
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
100   292  100   292    0     0    260      0  0:00:01  0:00:01 --:--:--   260
Installing Oracle VM VirtualBox Extension Pack from /home/jhull/.ievms/Oracle_VM_VirtualBox_Extension_Pack-4.1.18_RPMFusion-78361.vbox-extpack
VBoxManage: error: RTZipGzipDecompressIoStream failed: VERR_ZIP_BAD_HEADER
VBoxManage: error: Details: code NS_ERROR_FAILURE (0x80004005), component ExtPackFile, interface IExtPackFile, callee nsISupports
Context: "Install(fReplace, NULL, ptrProgress.asOutParam())" at line 1083 of file VBoxManageMisc.cpp

ERROR: Failed to install Oracle VM VirtualBox Extension Pack from /home/jhull/.ievms/Oracle_VM_VirtualBox_Extension_Pack-4.1.18_RPMFusion-78361.vbox-extpack, error code (0)

......then fails

Once I remove the "RPMFusion" bit from the version getting string everything works fine.

xdissent added a commit that referenced this issue Sep 23, 2012

@xdissent xdissent closed this Sep 23, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment