Skip to content

Misinterpretation of malicious XML input

Moderate
brodybits published GHSA-h6q6-9hqw-rwfv Mar 9, 2021

Package

npm xmldom (npm)

Affected versions

<= 0.4.0

Patched versions

None

Description

Impact

xmldom versions 0.4.0 and older do not correctly preserve system identifiers, FPIs or namespaces when repeatedly parsing and serializing maliciously crafted documents.

This may lead to unexpected syntactic changes during XML processing in some downstream applications.

Patches

Update to 0.5.0 (once it is released)

Workarounds

Downstream applications can validate the input and reject the maliciously crafted documents.

References

Similar to this one reported on the Go standard library:

For more information

If you have any questions or comments about this advisory:

  • Open an issue in xmldom/xmldom
  • Email us: send an email to all addresses that are shown by npm owner ls xmldom

CVE ID

CVE-2021-21366

Credits