setSecure deprecated on 0.3 #13

Closed
joaomachado opened this Issue Feb 11, 2011 · 3 comments

Comments

Projects
None yet
3 participants
@joaomachado

/home/jpaulo/Desktop/testes/xmpp/node-xmpp_git/lib/xmpp/connection.js:145
this.socket.setSecure(credentials || this.credentials);
^
TypeError: Object # has no method 'setSecure'
at Client.setSecure (/home/jpaulo/Desktop/testes/xmpp/node-xmpp_git/lib/xmpp/connection.js:145:17)
at Client.onStanza (/home/jpaulo/Desktop/testes/xmpp/node-xmpp_git/lib/xmpp/connection.js:167:14)
at StreamParser. (/home/jpaulo/Desktop/testes/xmpp/node-xmpp_git/lib/xmpp/connection.js:96:14)
at StreamParser.emit (events.js:42:17)
at [object Object]. (/home/jpaulo/Desktop/testes/xmpp/node-xmpp_git/lib/xmpp/stream_parser.js:38:22)
at StreamParser.write (/home/jpaulo/Desktop/testes/xmpp/node-xmpp_git/lib/xmpp/stream_parser.js:64:26)
at Client.onData (/home/jpaulo/Desktop/testes/xmpp/node-xmpp_git/lib/xmpp/connection.js:139:21)
at Socket. (/home/jpaulo/Desktop/testes/xmpp/node-xmpp_git/lib/xmpp/connection.js:29:14)
at Socket.emit (events.js:59:20)
at Socket._onReadable (net.js:649:14)

@astro

This comment has been minimized.

Show comment Hide comment
@astro

astro Feb 11, 2011

Owner

There was some discussion about that here: https://groups.google.com/forum/#!topic/nodejs-dev/oB_JZ6FhOSo/discussion

We have yet to find out how to STARTTLS in node 0.4.

Owner

astro commented Feb 11, 2011

There was some discussion about that here: https://groups.google.com/forum/#!topic/nodejs-dev/oB_JZ6FhOSo/discussion

We have yet to find out how to STARTTLS in node 0.4.

@dhruvbird

This comment has been minimized.

Show comment Hide comment
@dhruvbird

dhruvbird Mar 1, 2011

Contributor
Contributor

dhruvbird commented Mar 1, 2011

@astro

This comment has been minimized.

Show comment Hide comment
@astro

astro Mar 2, 2011

Owner

Fixed in v0.2.6.

I didn't retain compatibility to the old stable node 0.2.x. The dependency on 0.4.x is reflected in package.json.

Owner

astro commented Mar 2, 2011

Fixed in v0.2.6.

I didn't retain compatibility to the old stable node 0.2.x. The dependency on 0.4.x is reflected in package.json.

sonnyp pushed a commit that referenced this issue Jun 7, 2016

This issue was closed.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment