Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Updated the rakefile.

  • Loading branch information...
commit 0c8e621fc05d4c43f193a2ba9f9831ea719142cc 1 parent 183a7f2
Darrick Wiebe authored
Showing with 38 additions and 16 deletions.
  1. +5 −0 .document
  2. +17 −0 .gitignore
  3. +16 −16 Rakefile
View
5 .document
@@ -0,0 +1,5 @@
+lib/**/*.rb
+bin/*
+-
+features/**/*.feature
+LICENSE.txt
View
17 .gitignore
@@ -1,3 +1,20 @@
+# rcov generated
+coverage
+
+# rdoc generated
+rdoc
+
+# yard generated
+doc
+.yardoc
+
+# bundler
+.bundle
+
+# jeweler generated
+pkg
+
+# Project specific
*.graph
*.db
vendor/pipes*.jar
View
32 Rakefile
@@ -11,16 +11,26 @@ begin
gem.email = "darrick@innatesoftware.com"
gem.homepage = "http://github.com/pangloss/pacer"
gem.authors = ["Darrick Wiebe"]
+ gem.license = "MIT"
gem.add_dependency "nokogiri", "~> 1.4"
gem.add_development_dependency "rspec", "~> 2.1"
gem.add_development_dependency "rr", "~> 1.0"
gem.files = FileList['lib/**/*.rb', 'script/*', '[A-Z]*', 'spec/**/*', 'vendor/*'].to_a
# gem is a Gem::Specification... see http://www.rubygems.org/read/chapter/20 for additional settings
end
+ Jeweler::GemcutterTasks.new
+ Jeweler::RubygemsDotOrgTasks.new
rescue LoadError
puts "Jeweler (or a dependency) not available. Install it with: gem install jeweler"
end
+begin
+ require 'yard'
+ YARD::Rake::YardocTask.new
+rescue LoadError
+ puts "YARD not available. gem install yard"
+end
+
if Config::CONFIG['host_os'] =~ /mswin/
def jruby_path
Pathname.new ENV['path'].split(';').grep(/jruby/).first
@@ -44,18 +54,18 @@ if Config::CONFIG['host_os'] =~ /mswin/
end
end
task :install => jgem
+ task :build => jgem
end
end
-require 'spec/rake/spectask'
-Spec::Rake::SpecTask.new(:spec) do |spec|
- spec.libs << 'lib' << 'spec'
- spec.spec_files = FileList['spec/**/*_spec.rb']
+require 'rspec/core'
+require 'rspec/core/rake_task'
+RSpec::Core::RakeTask.new(:spec) do |spec|
+ spec.pattern = FileList['spec/**/*_spec.rb']
end
-Spec::Rake::SpecTask.new(:rcov) do |spec|
- spec.libs << 'lib' << 'spec'
+RSpec::Core::RakeTask.new(:rcov) do |spec|
spec.pattern = 'spec/**/*_spec.rb'
spec.rcov = true
end
@@ -63,13 +73,3 @@ end
task :spec => :check_dependencies
task :default => :spec
-
-require 'rake/rdoctask'
-Rake::RDocTask.new do |rdoc|
- version = File.exist?('VERSION') ? File.read('VERSION') : ""
-
- rdoc.rdoc_dir = 'rdoc'
- rdoc.title = "pacer #{version}"
- rdoc.rdoc_files.include('README*')
- rdoc.rdoc_files.include('lib/**/*.rb')
-end
Please sign in to comment.
Something went wrong with that request. Please try again.