Skip to content

@yes-maxheart yes-maxheart released this Apr 2, 2019 · 14 commits to master since this release

XPChain Core version 0.17.0-3 is now available from:

https://www.xpchain.io/?loc=lnkwallet

This update contains some essential bugfixes. IT IS STRONGLY RECOMMENDED to upgrade your clients to 0.17.0-3 immediately.

If you are still using an older version, you will be permanently unable to send coins and/or mint blocks.

See the release notes on GitHub:
https://github.com/xpc-wg/xpchain/blob/master/doc/xpchain-release-notes/xpchain-release-notes-0.17.0-3.md

What should I do when I failed to upgrade my wallet to 0.17.0-3?

If your wallet can't start after upgrading to 0.17.0-3, the block database is probably corrupted.

We have identified the issue of the wallet being unable to start or to synchronize with network, after block database rebuilding in response to an error message: “Corrupted block database detected Do you want to rebuild the block database now?


If you are on Windows, follow the steps below:

  1. Download xpc_0.17.0-3_cleanup_en.bat below
  2. Start it (by single-/double- clicking) and follow the instructions on the screen.

Note: use the program at your own risk, although it does never make any changes to your data of funds (e.g. wallet.dat)


If you are not on Windows or you are an expert, follow the steps below:

  1. Rename block directory in the data directory(*) to blocks_old
  2. Rename chainstate directory in the data directory(*) to chainstate_old
  3. Rename peers.dat in the data directory(*) to peers.dat.old
  4. Start the latest version (0.17.0-3) of XPChain Core

(*) By default, the data directory is located at %APPDATA%\XPChain or C:\Users\(your name)\AppData\Roming\XPChain (Windows), or /Users/(your name)/Library/Application Support/XPChain (macOS).

Assets 7

@yes-maxheart yes-maxheart released this Feb 2, 2019 · 110 commits to master since this release

Assets 5
Dec 24, 2018
Dec 23, 2018
You can’t perform that action at this time.