Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

1.11.4 버전일때 게시판에 첨부파일 업로드가 안됩니다. #2385

Closed
tubi55 opened this issue Mar 30, 2019 · 3 comments
Assignees
Milestone

Comments

@tubi55
Copy link

@tubi55 tubi55 commented Mar 30, 2019

밑에 파일첨부를 누르면 밑에 썸네일이 보이면서 본문삽입이라는 입력박스가 떠야되는데 그냥 닫히네요.

@bnu

This comment has been minimized.

Copy link
Member

@bnu bnu commented Apr 1, 2019

문제가 된 파일을 보내주실 수 있을까요?
bnu@xpressengine.com

@bnu bnu self-assigned this Apr 1, 2019
@kijin

This comment has been minimized.

Copy link
Contributor

@kijin kijin commented Apr 2, 2019

#2384 와 같은 문제일 것 같습니다.

매뉴얼이나 설치 모듈에서는 전혀 언급하지 않는 fileinfo 확장모듈을 아무 설명도 없이 갑자기 요구하기 시작하니 문제가 일어나는 것이 당연합니다. PHP에서 기본 제공되는 함수라는 말은 무의미합니다. 실제로 XE를 많이 사용하는 서버 환경에서 기본 제공되지 않을 가능성이 꽤 높은 확장모듈입니다.

전에는 필요하지 않았던 확장모듈이 앞으로는 필요하다고 정식으로 공지하고 마이너 버전을 변경하거나, 아니면 fileinfo 확장모듈이 없는 환경에서도 에러를 뿜지 않도록 조건문을 넣거나 대안을 마련해야 합니다.

@bnu bnu added this to the 1.11.6 milestone Oct 21, 2019
@bnu

This comment has been minimized.

Copy link
Member

@bnu bnu commented Oct 21, 2019

fileinfo 모듈이 없을 때 문제를 수정하고, 설치 시 조건을 확인하도록 했습니다.

bnu added a commit that referenced this issue Oct 22, 2019
@bnu bnu closed this Oct 24, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.