Skip to content
Branch: master
Find file History
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
..
Failed to load latest commit information.
linux
README
packages.yaml

README

# gcc@4.8.5
# spack install xsdk~ginkgo~phist~precice+cuda ^suite-sparse@5.1.0 && date

# module load gcc/7.4.0/gcc-4.8.5-4kde
# spack install xsdk%gcc@7.4.0+cuda

# module load intel/2018.1
# module load gcc/7.4.0/gcc-4.8.5-4kde
# spack install xsdk%intel@18.0.1 ^python%gcc@7.4.0 ^py-numpy%gcc@7.4.0 ^cmake%gcc@7.4.0 ^texinfo%gcc@7.4.0 ^diffutils%gcc@7.4.0


-bash-4.2$ ./spack/bin/spack find |cat
==> 73 installed packages
-- linux-centos7-haswell / gcc@4.8.5 ----------------------------
adol-c@develop
alquimia@xsdk-0.5.0
amrex@19.08
arpack-ng@3.7.0
autoconf@2.69
automake@1.16.1
boost@1.70.0
butterflypack@1.1.0
bzip2@1.0.8
cmake@3.15.5
cuda@10.1.168
dealii@9.1.1
diffutils@3.7
expat@2.2.9
findutils@4.6.0
gdbm@1.18.1
gettext@0.20.1
glm@0.9.7.1
gsl@2.5
hdf5@1.10.5
hypre@2.18.2
intel-tbb@2019.4
libbsd@0.9.1
libffi@3.2.1
libiconv@1.16
libpciaccess@0.13.5
libsigsegv@2.12
libtool@2.4.6
libxml2@2.9.9
m4@1.4.18
magma@2.5.1
matio@1.5.13
metis@5.1.0
mfem@4.0.1-xsdk
mpich@3.3.1
muparser@2.2.6.1
nanoflann@1.2.3
ncurses@6.1
netcdf-c@4.7.2
netlib-scalapack@2.0.2
numactl@2.0.12
oce@0.18.3
omega-h@9.29.0
openblas@0.3.7
openssl@1.1.1d
p4est@2.2
parmetis@4.0.3
perl@5.30.0
petsc@3.12.1
pflotran@xsdk-0.5.0
pkgconf@1.6.3
pumi@2.2.1
py-libensemble@0.5.2
py-mpi4py@3.0.3
py-numpy@1.17.4
py-petsc4py@3.12.0
py-setuptools@41.4.0
python@3.7.4
readline@8.0
slepc@3.12.0
sqlite@3.30.1
strumpack@3.3.0
suite-sparse@5.1.0
sundials@5.0.0
superlu-dist@6.1.1
tar@1.32
tasmanian@7.0
texinfo@6.5
trilinos@12.18.1
util-macros@1.19.1
xsdk@0.5.0
xz@5.2.4
zlib@1.2.11
-bash-4.2$ ./spack.x/bin/spack find |cat
==> 78 installed packages
-- linux-centos7-skylake_avx512 / gcc@7.4.0 ---------------------
adol-c@develop
alquimia@xsdk-0.5.0
amrex@19.08
arpack-ng@3.7.0
autoconf@2.69
automake@1.16.1
boost@1.70.0
butterflypack@1.1.0
bzip2@1.0.8
cmake@3.15.5
cuda@10.1.168
dealii@9.1.1
diffutils@3.7
eigen@3.3.7
expat@2.2.9
findutils@4.6.0
gdbm@1.18.1
gettext@0.20.1
ginkgo@1.1.0
glm@0.9.7.1
gsl@2.5
hdf5@1.10.5
hypre@2.18.2
intel-tbb@2019.4
libbsd@0.9.1
libffi@3.2.1
libiconv@1.16
libpciaccess@0.13.5
libsigsegv@2.12
libtool@2.4.6
libxml2@2.9.9
m4@1.4.18
magma@2.5.1
matio@1.5.13
metis@5.1.0
mfem@4.0.1-xsdk
mpich@3.3.1
muparser@2.2.6.1
nanoflann@1.2.3
ncurses@6.1
netcdf-c@4.7.2
netlib-scalapack@2.0.2
numactl@2.0.12
oce@0.18.3
omega-h@9.29.0
openblas@0.3.7
openssl@1.1.1d
p4est@2.2
parmetis@4.0.3
perl@5.30.0
petsc@3.12.1
pflotran@xsdk-0.5.0
phist@1.8.0
pkgconf@1.6.3
plasma@19.8.1
precice@1.6.1
pumi@2.2.1
py-libensemble@0.5.2
py-mpi4py@3.0.3
py-numpy@1.17.4
py-petsc4py@3.12.0
py-setuptools@41.4.0
python@3.7.4
readline@8.0
slepc@3.12.0
sqlite@3.30.1
strumpack@3.3.0
suite-sparse@5.3.0
sundials@5.0.0
superlu-dist@6.1.1
tar@1.32
tasmanian@7.0
texinfo@6.5
trilinos@12.18.1
util-macros@1.19.1
xsdk@0.5.0
xz@5.2.4
zlib@1.2.11
-bash-4.2$ ./spack.y/bin/spack find |cat
==> 75 installed packages
-- linux-centos7-skylake_avx512 / gcc@7.4.0 ---------------------
cmake@3.15.5
diffutils@3.7
expat@2.2.9
gettext@0.20.1
libbsd@0.9.1
libffi@3.2.1
ncurses@6.1
openssl@1.1.1d
py-numpy@1.17.4
python@3.7.4
sqlite@3.30.1
tar@1.32
texinfo@6.5

-- linux-centos7-skylake_avx512 / intel@18.0.1 ------------------
adol-c@develop
alquimia@xsdk-0.5.0
amrex@19.08
arpack-ng@3.7.0
autoconf@2.69
automake@1.16.1
boost@1.70.0
butterflypack@1.1.0
bzip2@1.0.8
dealii@9.1.1
eigen@3.3.7
findutils@4.6.0
gdbm@1.18.1
ginkgo@1.1.0
glm@0.9.7.1
gsl@2.5
hdf5@1.10.5
hypre@2.18.2
intel-tbb@2019.4
libiconv@1.16
libpciaccess@0.13.5
libsigsegv@2.12
libtool@2.4.6
libxml2@2.9.9
m4@1.4.18
matio@1.5.13
metis@5.1.0
mfem@4.0.1-xsdk
mpich@3.3.1
muparser@2.2.6.1
nanoflann@1.2.3
netcdf-c@4.7.2
netlib-scalapack@2.0.2
numactl@2.0.12
oce@0.18.3
omega-h@9.29.0
openblas@0.3.7
p4est@2.2
parmetis@4.0.3
perl@5.30.0
petsc@3.12.1
pflotran@xsdk-0.5.0
phist@1.8.0
pkgconf@1.6.3
precice@1.6.1
pumi@2.2.1
py-libensemble@0.5.2
py-mpi4py@3.0.3
py-petsc4py@3.12.0
py-setuptools@41.4.0
readline@8.0
slepc@3.12.0
strumpack@3.3.0
suite-sparse@5.3.0
sundials@5.0.0
superlu-dist@6.1.1
tasmanian@7.0
trilinos@12.18.1
util-macros@1.19.1
xsdk@0.5.0
xz@5.2.4
zlib@1.2.11
-bash-4.2$ 

You can’t perform that action at this time.