Skip to content

xuafeng/zgrab_

master
Switch branches/tags

Name already in use

A tag already exists with the provided branch name. Many Git commands accept both tag and branch names, so creating this branch may cause unexpected behavior. Are you sure you want to create this branch?
Code

Latest commit

 

Git stats

Files

Permalink
Failed to load latest commit information.
Type
Name
Latest commit message
Commit time
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

zgrab

Build Status

A TLS Banner Grabber, in Go

Building

You will need to have a valid $GOPATH set up, for more information about $GOPATH, see https://golang.org/doc/code.html.

Once you have a working $GOPATH, run:

go get github.com/zmap/zgrab

This will install zgrab under $GOPATH/src/github.com/zmap/zgrab

$ cd $GOPATH/src/github.com/zmap/zgrab
$ go build

Usage

./zgrab --help

Example

$ zmap -p 443 --output-fields=* | ztee --output-file=results.csv | zgrab --port 443 --tls --data=./http-req --output-file=banners.json

Requirements

zgrab requires go version of at least 1.3.3. Please note that this is newer than the version included in Ubuntu 14.04 apt repository. You can install ztee from ZMap Github repository at https://github.com/zmap/zmap.

ZGrab as a library / dependency

If you are using ZGrab code in another Go program, import ZGrab using gopkg.in. ZGrab tends to be very unstable, API's may break at any time, so use gopkg.in or another go dependency management to lock what version of ZGrab you use.

gopkg.in/zmap/zgrab.v0.0.1

License

ZGrab is licensed under Apache 2.0 and ISC. For more information, see the LICENSE file.

About

add s7

Resources

License

Stars

Watchers

Forks

Releases

No releases published

Packages

No packages published