Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

XECLIPSE-155: XEclipse RESTification

* Finalized the merge of GSoC 2011 work done by Jun Han <jun.han37@gmail.com>
* Version bump to 2.0.0-SNAPSHOT (http://xwiki.markmail.org/thread/fthxqh6vlue2gmrk)
  • Loading branch information...
commit 4290a3ecb8615d54ecd354470a983471808012f8 1 parent ddcd810
Fabio Mancinelli fmancinelli authored
Showing with 47 additions and 47 deletions.
  1. +6 −6 features/org.xwiki.eclipse.feature/feature.xml
  2. +2 −2 features/org.xwiki.eclipse.feature/pom.xml
  3. +1 −1  features/pom.xml
  4. +2 −2 plugins/org.xwiki.eclipse.core/META-INF/MANIFEST.MF
  5. +1 −1  plugins/org.xwiki.eclipse.core/pom.xml
  6. +2 −2 plugins/org.xwiki.eclipse.rcp/META-INF/MANIFEST.MF
  7. +2 −2 plugins/org.xwiki.eclipse.rcp/org.xwiki.eclipse.product
  8. +1 −1  plugins/org.xwiki.eclipse.rcp/pom.xml
  9. +1 −1  plugins/org.xwiki.eclipse.rest/META-INF/MANIFEST.MF
  10. +2 −2 plugins/org.xwiki.eclipse.rest/pom.xml
  11. +3 −3 plugins/org.xwiki.eclipse.storage/META-INF/MANIFEST.MF
  12. +2 −2 plugins/org.xwiki.eclipse.storage/pom.xml
  13. +3 −3 plugins/org.xwiki.eclipse.test/META-INF/MANIFEST.MF
  14. +2 −2 plugins/org.xwiki.eclipse.test/pom.xml
  15. +3 −3 plugins/org.xwiki.eclipse.ui/META-INF/MANIFEST.MF
  16. +1 −1  plugins/org.xwiki.eclipse.ui/pom.xml
  17. +1 −1  plugins/org.xwiki.eclipse.xmlrpc/META-INF/MANIFEST.MF
  18. +2 −2 plugins/org.xwiki.eclipse.xmlrpc/pom.xml
  19. +1 −1  plugins/pom.xml
  20. +1 −1  pom.xml
  21. +2 −2 product/org.xwiki.eclipse.product
  22. +1 −1  product/pom.xml
  23. +2 −2 repository/category.xml
  24. +1 −1  repository/pom.xml
  25. +1 −1  site/pom.xml
  26. +1 −1  site/site.xml
12 features/org.xwiki.eclipse.feature/feature.xml
View
@@ -2,7 +2,7 @@
<feature
id="org.xwiki.eclipse.feature"
label="XWiki Eclipse Feature"
- version="1.2.0.qualifier"
+ version="2.0.0.qualifier"
provider-name="XWiki">
<description url="http://code.xwiki.org/xwiki/bin/view/Extensions/XEclipseExtension">
@@ -51,8 +51,8 @@ if not, write to the Free Software Foundation, Inc.,
<import plugin="org.eclipse.core.runtime" version="3.6.0" match="greaterOrEqual"/>
<import plugin="org.eclipse.core.resources" version="3.6.1" match="greaterOrEqual"/>
<import plugin="org.eclipse.core.expressions" version="3.4.200" match="greaterOrEqual"/>
- <import plugin="org.xwiki.eclipse.xmlrpc" version="1.2.0" match="greaterOrEqual"/>
- <import plugin="org.xwiki.eclipse.storage" version="1.2.0" match="greaterOrEqual"/>
+ <import plugin="org.xwiki.eclipse.xmlrpc" version="2.0.0" match="greaterOrEqual"/>
+ <import plugin="org.xwiki.eclipse.storage" version="2.0.0" match="greaterOrEqual"/>
<import plugin="org.eclipse.ui" version="3.6.2" match="greaterOrEqual"/>
<import plugin="org.eclipse.ui.ide" version="3.6.2" match="greaterOrEqual"/>
<import plugin="org.eclipse.ui.navigator" version="3.5.0" match="greaterOrEqual"/>
@@ -62,11 +62,11 @@ if not, write to the Free Software Foundation, Inc.,
<import plugin="org.eclipse.ui.forms" version="3.5.2" match="greaterOrEqual"/>
<import plugin="org.eclipse.jface.text" version="3.6.1" match="greaterOrEqual"/>
<import plugin="org.eclipse.compare" version="3.5.101" match="greaterOrEqual"/>
- <import plugin="org.xwiki.eclipse.core" version="1.2.0" match="greaterOrEqual"/>
+ <import plugin="org.xwiki.eclipse.core" version="2.0.0" match="greaterOrEqual"/>
<import plugin="org.eclipse.ui.views.log" version="1.0.100" match="greaterOrEqual"/>
- <import plugin="org.xwiki.eclipse.ui" version="1.2.0" match="greaterOrEqual"/>
+ <import plugin="org.xwiki.eclipse.ui" version="2.0.0" match="greaterOrEqual"/>
<import plugin="org.eclipse.swt" version="3.0.0" match="compatible"/>
- <import plugin="org.xwiki.eclipse.rest" version="1.2.0" match="greaterOrEqual"/>
+ <import plugin="org.xwiki.eclipse.rest" version="2.0.0" match="greaterOrEqual"/>
</requires>
<plugin
4 features/org.xwiki.eclipse.feature/pom.xml
View
@@ -28,12 +28,12 @@
<parent>
<artifactId>org.xwiki.eclipse.features</artifactId>
<groupId>org.xwiki.eclipse</groupId>
- <version>1.2.0-SNAPSHOT</version>
+ <version>2.0.0-SNAPSHOT</version>
</parent>
<modelVersion>4.0.0</modelVersion>
<groupId>org.xwiki.eclipse</groupId>
<artifactId>org.xwiki.eclipse.feature</artifactId>
- <version>1.2.0-SNAPSHOT</version>
+ <version>2.0.0-SNAPSHOT</version>
<packaging>eclipse-feature</packaging>
</project>
2  features/pom.xml
View
@@ -28,7 +28,7 @@
<parent>
<artifactId>org.xwiki.eclipse</artifactId>
<groupId>org.xwiki.eclipse</groupId>
- <version>1.2.0-SNAPSHOT</version>
+ <version>2.0.0-SNAPSHOT</version>
</parent>
<modelVersion>4.0.0</modelVersion>
4 plugins/org.xwiki.eclipse.core/META-INF/MANIFEST.MF
View
@@ -2,13 +2,13 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: XWiki Eclipse Core Plug-in
Bundle-SymbolicName: org.xwiki.eclipse.core;singleton:=true
-Bundle-Version: 1.2.0.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Activator: org.xwiki.eclipse.core.CorePlugin
Bundle-Vendor: XWiki
Require-Bundle: org.eclipse.core.runtime;bundle-version="3.6.0",
org.eclipse.core.resources;bundle-version="3.6.1",
org.eclipse.core.expressions;bundle-version="3.4.200",
- org.xwiki.eclipse.storage;bundle-version="1.2.0"
+ org.xwiki.eclipse.storage;bundle-version="2.0.0"
Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Export-Package: org.xwiki.eclipse.core,
org.xwiki.eclipse.core.expressions
2  plugins/org.xwiki.eclipse.core/pom.xml
View
@@ -29,7 +29,7 @@
<parent>
<artifactId>org.xwiki.eclipse.plugins</artifactId>
<groupId>org.xwiki.eclipse</groupId>
- <version>1.2.0-SNAPSHOT</version>
+ <version>2.0.0-SNAPSHOT</version>
</parent>
<artifactId>org.xwiki.eclipse.core</artifactId>
<packaging>eclipse-plugin</packaging>
4 plugins/org.xwiki.eclipse.rcp/META-INF/MANIFEST.MF
View
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: XWiki Eclipse
Bundle-SymbolicName: org.xwiki.eclipse.rcp;singleton:=true
-Bundle-Version: 1.2.0.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Activator: org.xwiki.eclipse.rcp.Activator
Require-Bundle: org.eclipse.ui;bundle-version="3.6.2",
org.eclipse.core.runtime;bundle-version="3.6.0",
@@ -11,7 +11,7 @@ Require-Bundle: org.eclipse.ui;bundle-version="3.6.2",
org.eclipse.ui.navigator.resources;bundle-version="3.4.202",
org.eclipse.ui.views;bundle-version="3.5.1",
org.eclipse.ui.views.log;bundle-version="1.0.100",
- org.xwiki.eclipse.ui;bundle-version="1.2.0"
+ org.xwiki.eclipse.ui;bundle-version="2.0.0"
Bundle-Vendor: XWiki
Export-Package: org.xwiki.eclipse.rcp
Bundle-RequiredExecutionEnvironment: JavaSE-1.6
4 plugins/org.xwiki.eclipse.rcp/org.xwiki.eclipse.product
View
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<?pde version="3.5"?>
-<product name="XWiki Eclipse" uid="org.xwiki.eclipse.product" id="org.xwiki.eclipse.product" application="org.xwiki.eclipse.rcp.application" version="1.2.0.qualifier" useFeatures="true" includeLaunchers="true">
+<product name="XWiki Eclipse" uid="org.xwiki.eclipse.product" id="org.xwiki.eclipse.product" application="org.xwiki.eclipse.rcp.application" version="2.0.0.qualifier" useFeatures="true" includeLaunchers="true">
<aboutInfo>
<image path="/org.xwiki.eclipse.rcp/icons/about.png"/>
@@ -30,7 +30,7 @@
</launcher>
<features>
- <feature id="org.xwiki.eclipse.feature" version="1.2.0.qualifier"/>
+ <feature id="org.xwiki.eclipse.feature" version="2.0.0.qualifier"/>
<feature id="org.eclipse.rcp"/>
</features>
2  plugins/org.xwiki.eclipse.rcp/pom.xml
View
@@ -28,7 +28,7 @@
<parent>
<artifactId>org.xwiki.eclipse.plugins</artifactId>
<groupId>org.xwiki.eclipse</groupId>
- <version>1.2.0-SNAPSHOT</version>
+ <version>2.0.0-SNAPSHOT</version>
</parent>
<modelVersion>4.0.0</modelVersion>
<artifactId>org.xwiki.eclipse.rcp</artifactId>
2  plugins/org.xwiki.eclipse.rest/META-INF/MANIFEST.MF
View
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: XWiki Eclipse Rest Plugin
Bundle-SymbolicName: org.xwiki.eclipse.rest;singleton:=true
-Bundle-Version: 1.2.0.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Vendor: XWiki
Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Require-Bundle: org.eclipse.core.runtime;bundle-version="3.6.0"
4 plugins/org.xwiki.eclipse.rest/pom.xml
View
@@ -29,11 +29,11 @@
<parent>
<artifactId>org.xwiki.eclipse.plugins</artifactId>
<groupId>org.xwiki.eclipse</groupId>
- <version>1.2.0-SNAPSHOT</version>
+ <version>2.0.0-SNAPSHOT</version>
</parent>
<groupId>org.xwiki.eclipse</groupId>
<artifactId>org.xwiki.eclipse.rest</artifactId>
- <version>1.2.0-SNAPSHOT</version>
+ <version>2.0.0-SNAPSHOT</version>
<properties>
<xwiki.version>3.1-SNAPSHOT</xwiki.version>
6 plugins/org.xwiki.eclipse.storage/META-INF/MANIFEST.MF
View
@@ -2,13 +2,13 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: XWiki Eclipse Storage Plugin
Bundle-SymbolicName: org.xwiki.eclipse.storage;singleton:=true
-Bundle-Version: 1.2.0.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Vendor: XWiki
Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Require-Bundle: org.eclipse.core.runtime;bundle-version="3.6.0",
org.eclipse.core.resources;bundle-version="3.6.1",
- org.xwiki.eclipse.xmlrpc;bundle-version="1.2.0",
- org.xwiki.eclipse.rest;bundle-version="1.2.0"
+ org.xwiki.eclipse.xmlrpc;bundle-version="2.0.0",
+ org.xwiki.eclipse.rest;bundle-version="2.0.0"
Bundle-ClassPath: .,
lib/gson-1.7.1.jar
Export-Package: org.xwiki.eclipse.model,
4 plugins/org.xwiki.eclipse.storage/pom.xml
View
@@ -29,10 +29,10 @@
<parent>
<artifactId>org.xwiki.eclipse.plugins</artifactId>
<groupId>org.xwiki.eclipse</groupId>
- <version>1.2.0-SNAPSHOT</version>
+ <version>2.0.0-SNAPSHOT</version>
</parent>
<groupId>org.xwiki.eclipse</groupId>
<artifactId>org.xwiki.eclipse.storage</artifactId>
- <version>1.2.0-SNAPSHOT</version>
+ <version>2.0.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
</project>
6 plugins/org.xwiki.eclipse.test/META-INF/MANIFEST.MF
View
@@ -2,12 +2,12 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: XWiki Eclipse Test Plugin
Bundle-SymbolicName: org.xwiki.eclipse.test;singleton:=true
-Bundle-Version: 1.2.0.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Vendor: XWiki
Bundle-RequiredExecutionEnvironment: JavaSE-1.6
-Require-Bundle: org.xwiki.eclipse.storage;bundle-version="1.2.0",
+Require-Bundle: org.xwiki.eclipse.storage;bundle-version="2.0.0",
org.junit;bundle-version="4.8.2",
- org.xwiki.eclipse.rest;bundle-version="1.2.0",
+ org.xwiki.eclipse.rest;bundle-version="2.0.0",
org.eclipse.core.runtime;bundle-version="3.6.0",
org.eclipse.core.resources;bundle-version="3.6.100",
org.eclipse.core.filesystem;bundle-version="1.3.100"
4 plugins/org.xwiki.eclipse.test/pom.xml
View
@@ -29,10 +29,10 @@
<parent>
<artifactId>org.xwiki.eclipse.plugins</artifactId>
<groupId>org.xwiki.eclipse</groupId>
- <version>1.2.0-SNAPSHOT</version>
+ <version>2.0.0-SNAPSHOT</version>
</parent>
<groupId>org.xwiki.eclipse</groupId>
<artifactId>org.xwiki.eclipse.test</artifactId>
- <version>1.2.0-SNAPSHOT</version>
+ <version>2.0.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
</project>
6 plugins/org.xwiki.eclipse.ui/META-INF/MANIFEST.MF
View
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: XWiki Eclipse UI Plug-in
Bundle-SymbolicName: org.xwiki.eclipse.ui;singleton:=true
-Bundle-Version: 1.2.0.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Activator: org.xwiki.eclipse.ui.UIPlugin
Bundle-Vendor: XWiki
Require-Bundle: org.eclipse.ui;bundle-version="3.6.2",
@@ -17,8 +17,8 @@ Require-Bundle: org.eclipse.ui;bundle-version="3.6.2",
org.eclipse.core.resources;bundle-version="3.6.1",
org.eclipse.compare;bundle-version="3.5.101",
org.eclipse.core.expressions;bundle-version="3.4.200",
- org.xwiki.eclipse.storage;bundle-version="1.2.0",
- org.xwiki.eclipse.core;bundle-version="1.2.0"
+ org.xwiki.eclipse.storage;bundle-version="2.0.0",
+ org.xwiki.eclipse.core;bundle-version="2.0.0"
Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Export-Package: org.xwiki.eclipse.ui.perspectives
Bundle-ActivationPolicy: lazy
2  plugins/org.xwiki.eclipse.ui/pom.xml
View
@@ -28,7 +28,7 @@
<parent>
<artifactId>org.xwiki.eclipse.plugins</artifactId>
<groupId>org.xwiki.eclipse</groupId>
- <version>1.2.0-SNAPSHOT</version>
+ <version>2.0.0-SNAPSHOT</version>
</parent>
<modelVersion>4.0.0</modelVersion>
2  plugins/org.xwiki.eclipse.xmlrpc/META-INF/MANIFEST.MF
View
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: XWiki Eclipse XmlRpc Plug-in
Bundle-SymbolicName: org.xwiki.eclipse.xmlrpc;singleton:=true
-Bundle-Version: 1.2.0.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-ClassPath: junit-3.8.1.jar,
swizzle-confluence-1.2-20080419-xwiki.jar,
ws-commons-util-1.0.2.jar,
4 plugins/org.xwiki.eclipse.xmlrpc/pom.xml
View
@@ -29,10 +29,10 @@
<parent>
<artifactId>org.xwiki.eclipse.plugins</artifactId>
<groupId>org.xwiki.eclipse</groupId>
- <version>1.2.0-SNAPSHOT</version>
+ <version>2.0.0-SNAPSHOT</version>
</parent>
<groupId>org.xwiki.eclipse</groupId>
<artifactId>org.xwiki.eclipse.xmlrpc</artifactId>
- <version>1.2.0-SNAPSHOT</version>
+ <version>2.0.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
</project>
2  plugins/pom.xml
View
@@ -28,7 +28,7 @@
<parent>
<artifactId>org.xwiki.eclipse</artifactId>
<groupId>org.xwiki.eclipse</groupId>
- <version>1.2.0-SNAPSHOT</version>
+ <version>2.0.0-SNAPSHOT</version>
</parent>
<modelVersion>4.0.0</modelVersion>
2  pom.xml
View
@@ -28,7 +28,7 @@
<modelVersion>4.0.0</modelVersion>
<groupId>org.xwiki.eclipse</groupId>
<artifactId>org.xwiki.eclipse</artifactId>
- <version>1.2.0-SNAPSHOT</version>
+ <version>2.0.0-SNAPSHOT</version>
<packaging>pom</packaging>
<!-- tycho requires maven >= 3.0 -->
4 product/org.xwiki.eclipse.product
View
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<?pde version="3.5"?>
-<product name="XWiki Eclipse" uid="org.xwiki.eclipse.product" id="org.xwiki.eclipse.product" application="org.xwiki.eclipse.rcp.application" version="1.2.0.qualifier" useFeatures="true" includeLaunchers="true">
+<product name="XWiki Eclipse" uid="org.xwiki.eclipse.product" id="org.xwiki.eclipse.product" application="org.xwiki.eclipse.rcp.application" version="2.0.0.qualifier" useFeatures="true" includeLaunchers="true">
<aboutInfo>
<image path="/org.xwiki.eclipse.rcp/icons/about.png"/>
@@ -30,7 +30,7 @@
</launcher>
<features>
- <feature id="org.xwiki.eclipse.feature" version="1.2.0.qualifier"/>
+ <feature id="org.xwiki.eclipse.feature" version="2.0.0.qualifier"/>
<feature id="org.eclipse.rcp"/>
</features>
2  product/pom.xml
View
@@ -29,7 +29,7 @@
<parent>
<artifactId>org.xwiki.eclipse</artifactId>
<groupId>org.xwiki.eclipse</groupId>
- <version>1.2.0-SNAPSHOT</version>
+ <version>2.0.0-SNAPSHOT</version>
</parent>
<artifactId>org.xwiki.eclipse.product</artifactId>
4 repository/category.xml
View
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<site>
- <feature url="features/org.xwiki.eclipse.feature_1.2.0.qualifier.jar"
- id="org.xwiki.eclipse.feature" version="1.2.0.qualifier">
+ <feature url="features/org.xwiki.eclipse.feature_2.0.0.qualifier.jar"
+ id="org.xwiki.eclipse.feature" version="2.0.0.qualifier">
<category name="org.xwiki.eclipse.repository" />
</feature>
<category-def name="org.xwiki.eclipse.repository" label="org.xwiki.eclipse.repository">
2  repository/pom.xml
View
@@ -29,7 +29,7 @@
<parent>
<artifactId>org.xwiki.eclipse</artifactId>
<groupId>org.xwiki.eclipse</groupId>
- <version>1.2.0-SNAPSHOT</version>
+ <version>2.0.0-SNAPSHOT</version>
</parent>
<artifactId>org.xwiki.eclipse.repository</artifactId>
<packaging>eclipse-repository</packaging>
2  site/pom.xml
View
@@ -29,7 +29,7 @@
<parent>
<artifactId>org.xwiki.eclipse</artifactId>
<groupId>org.xwiki.eclipse</groupId>
- <version>1.2.0-SNAPSHOT</version>
+ <version>2.0.0-SNAPSHOT</version>
</parent>
<artifactId>org.xwiki.eclipse.site</artifactId>
<packaging>eclipse-update-site</packaging>
2  site/site.xml
View
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<site>
- <feature url="features/org.xwiki.eclipse.feature_1.2.0.qualifier.jar" id="org.xwiki.eclipse.feature" version="1.2.0.qualifier">
+ <feature url="features/org.xwiki.eclipse.feature_2.0.0.qualifier.jar" id="org.xwiki.eclipse.feature" version="2.0.0.qualifier">
<category name="org.xwiki.eclipse.category"/>
</feature>
<category-def name="org.xwiki.eclipse.category" label="org.xwiki.eclipse.category">
Please sign in to comment.
Something went wrong with that request. Please try again.