Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

With each click on the "Check connection" button the "Test connection" message multiplies #30

Closed
ane-gabriela opened this issue Apr 9, 2020 · 0 comments
Assignees
Milestone

Comments

@ane-gabriela
Copy link

ane-gabriela commented Apr 9, 2020

Steps to reproduce:

  1. Connect to the AD (follow the steps from Test Connection
  2. In Administer Wiki > Other > Active Directory make sure you added valid AD credentials
  3. Click on the Check connection button
  4. Click on Check connection again

Expected results: "Test connection succeeded!" appears.

Actual results: Witch each click of the button a new "Test connection succeeded!" info message appears.

Environment: Windows 10, XWiki 11.10.4 with MySQL 5.7 and Chrome 80, Active Directory Application 1.8.1

TestConnection

@ane-gabriela ane-gabriela added this to the 1.9 milestone Apr 9, 2020
@acotiuga acotiuga self-assigned this Jul 2, 2020
@acotiuga acotiuga modified the milestones: 1.9, 1.8.2 Jul 2, 2020
acotiuga added a commit that referenced this issue Jul 2, 2020
…" message multiplies #30

* before displaying the response, clear any other existing response from a previous check.
* update the respoonse content instead of appending data to the existing one
@acotiuga acotiuga closed this as completed Jul 2, 2020
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Development

No branches or pull requests

2 participants