Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Active Directory user and groups mapping fields aren't shown with IE 11, can't add new entries #33

Closed
ane-gabriela opened this issue Apr 23, 2020 · 0 comments

Comments

@ane-gabriela
Copy link

ane-gabriela commented Apr 23, 2020

Preconditions: Have the AD configured in XWiki

Steps to reproduce:

  1. Log in as Admin in XWiki with IE 11
  2. Access Administer Wiki> Other > Active Directory
  3. Click on "Show Advanced Configuration"
  4. Observe the fields under "Active Directory user fields mapping" and "Active Directory groups mapping"

Expected results: The fields appear and the user can populate and add new entries.

Actual results: The text boxes and the option to add a New Entry aren't shown on IE 11.
IE11

Environment: Windows 10, XWiki 11.10.4 with MySQL 5.7, IE 11 and Chrome 81, Active Directory Application 1.8.1

@ane-gabriela ane-gabriela modified the milestones: 1.8.1, 1.9 Apr 23, 2020
acotiuga added a commit that referenced this issue Jun 29, 2020
…11, can't add new entries #33

* ParentNode.append() is not supported by IE
@acotiuga acotiuga self-assigned this Jun 29, 2020
acotiuga added a commit that referenced this issue Jun 30, 2020
…11, can't add new entries #33

* use properly jQuery objects and avoid prototyeJS and native JavaScript
* thanks to @mflorea for remarks
acotiuga added a commit that referenced this issue Jun 30, 2020
…11, can't add new entries #33

* code improvements
@acotiuga acotiuga modified the milestones: 1.9, 1.8.2 Jul 2, 2020
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Development

No branches or pull requests

2 participants