Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

The Antivirus application causes Attachment*Events to not be triggered #30

Closed
Enygma2002 opened this issue Jul 8, 2021 · 0 comments
Closed

Comments

@Enygma2002
Copy link
Contributor

Example side-effect: When deleting an attachment from a wiki page, the Solr search index is not updated and the file can still be found with search, even if you can not access it if you follow the search result.

Reported product issue: https://jira.xwiki.org/browse/XWIKI-18775

For Antivirus, we can apply the workaround mentioned in the product issue.

Tested on XWiki 12.10.6, but it could be causing issues as early as 11.3-rc-1, 10.11.7, if the root cause is indeed https://jira.xwiki.org/browse/XWIKI-15805.

@Enygma2002 Enygma2002 self-assigned this Jul 8, 2021
Enygma2002 added a commit that referenced this issue Jul 8, 2021
…#30

* Using the workaround by cloning the source document and its original document.
* Updated the tests.
@Enygma2002 Enygma2002 added this to the 1.3.3 milestone Jul 8, 2021
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Development

No branches or pull requests

1 participant