Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Can't install Google Apps #26

ane-gabriela opened this issue Sep 3, 2019 · 2 comments

Can't install Google Apps #26

ane-gabriela opened this issue Sep 3, 2019 · 2 comments


Copy link

Steps to reproduce:

  1. Access a cloud instance or a local one
  2. Install the Google App 2.4

Expected results: The app is installed.

Actual results: The app can't be installed, compatibility issues appear.

Environment: XWiki 10.11.9 and 8.4.5 with Chrome 76

8 4 5
10 11 9

Copy link

mflorea commented Sep 3, 2019

Regression caused by 68af57f .

EM resolves the dependency tree differently than Maven does. With Maven you get this . If you look for org.apache.httpcomponents:httpclient you'll see it is resolved to version 4.5.2. But this is not right at runtime. If you try to install the app with EM you get this . EM resolves org.apache.httpcomponents:httpclient to version 4.5.9. There are two paths in the dependency tree that lead to org.apache.httpcomponents:httpclient. See . google-http-client doen't specify the version of httpclient and its parent pom has this


It's not clear why EM wants 4.5.9 and not 4.5.8 but it doesn't matter. The fact is that google-api-client 1.30.2 has a transitive dependency on httpclient 4.5.8 which is not compatible with the 4.5.2 version available in XWiki 8.4. ATM we can only upgrade to something that uses google-http-client 1.23.0, see .

Note that httpclient 4.5.9 is available in XWiki only since 11.5RC1, and 4.5.8 since 11.3RC1, so we won't be able to upgrade to the latest google-http-client too soon..

Copy link

mflorea commented Sep 3, 2019

@tmortagne tells me that the enforcer plugin would have helped us catching this type of issues at build time, but this check is enabled since XWiki 9.0RC1. So until we upgrade our parent to 9.x we need to test at runtime with EM the dependency upgrades we do.

acotiuga added a commit that referenced this issue Sep 4, 2019
* update the dependencies to the highest versions that will require the same version as XWiki 8.4 for the problematic transitive dependencies
@acotiuga acotiuga closed this as completed Sep 4, 2019
@acotiuga acotiuga modified the milestones: 2.5, 2.4.1 Sep 4, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
None yet

No branches or pull requests

3 participants