Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Throwing a warning in the admin when Show Avatars is disabled. #518

Closed
Japh opened this issue May 10, 2014 · 6 comments

Comments

Projects
None yet
4 participants
@Japh
Copy link

commented May 10, 2014

Just updated my sites to Stream 1.4.4 and noticed that when Show Avatars is disabled (not selected) in Settings > Discussion, the following warning is displayed, twice for each "author", at the top of the Stream admin page:

Warning: assert(): Assertion failed in /home/[...]/public_html/wp-content/plugins/stream/includes/class-wp-stream-author.php on line 119

Doesn't break the site, but it definitely doesn't look good. Thought you'd want to know...

Originally reported on the WordPress.org forums

@shadyvb

This comment has been minimized.

Copy link
Contributor

commented May 10, 2014

I'm on it.

@shadyvb shadyvb self-assigned this May 10, 2014

Japh pushed a commit that referenced this issue May 10, 2014

@Japh

This comment has been minimized.

Copy link
Author

commented May 10, 2014

No, I am :)

@shadyvb

This comment has been minimized.

Copy link
Contributor

commented May 10, 2014

@Japh wp-cli avatar still shows while the 'show_avatars' setting is disabled, we might need to address this here as well.

@westonruter

This comment has been minimized.

Copy link
Contributor

commented May 10, 2014

Oh yeah. The WP_Stream_Author class manually supplies an image for the
system user.

Japh pushed a commit that referenced this issue May 10, 2014

Japh
@Japh

This comment has been minimized.

Copy link
Author

commented May 10, 2014

Thanks for the heads up, @shadyvb. Fixed that now.

@shadyvb

This comment has been minimized.

Copy link
Contributor

commented May 10, 2014

Cool, @fjarrett This needs to be issued as a hotfix to prevent notices on installations with show_avatars=false, probably lots of them are there.

fjarrett added a commit that referenced this issue May 11, 2014

Merge pull request #519 from x-team/issue-518
Fix for Show Avatars disabled, issue #518

@fjarrett fjarrett closed this May 11, 2014

@Japh Japh removed their assignment Aug 24, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.