New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

#41274: Expose link input in widget #243

Closed
wants to merge 5 commits into
base: master
from

Conversation

Projects
None yet
2 participants
@timmyc
Collaborator

timmyc commented Jul 28, 2017

This branch explores a design that displays the link_url input form for the image widget in the widget itself to make it more discoverable.

See mockups: https://cloudup.com/cTX3XurZQBJ

@westonruter westonruter changed the title from Expose link input in widget to #41274: Expose link input in widget Aug 10, 2017

@timmyc

This comment has been minimized.

Show comment
Hide comment
@timmyc

timmyc Aug 11, 2017

Collaborator

@westonruter made some updates based upon your feedback.

Collaborator

timmyc commented Aug 11, 2017

@westonruter made some updates based upon your feedback.

@westonruter

This comment has been minimized.

Show comment
Hide comment
@westonruter

westonruter Aug 12, 2017

Member

@timmyc I noticed a few more issues related to changing the the link type and link URL across the edit frame, select frame, and extra field. I could sometimes get this to happen:

image

And sometimes when changing the link type in the edit frame, it would cause the new link URL field to clear out. Also when switching the selected media, sometimes the URL would not update as I switched. And other times, when I'd change the custom URL it would not show up in the media select frame.

Hard to pinpoint and reproduce the steps to reproduce the issues I found, but after tweaking things for awhile I got it to a state where I wasn't able to encounter any further oddities: fbdb3e0

If that all looks and tests well for you, please confirm and then I'll commit.

/cc @melchoyce

Member

westonruter commented Aug 12, 2017

@timmyc I noticed a few more issues related to changing the the link type and link URL across the edit frame, select frame, and extra field. I could sometimes get this to happen:

image

And sometimes when changing the link type in the edit frame, it would cause the new link URL field to clear out. Also when switching the selected media, sometimes the URL would not update as I switched. And other times, when I'd change the custom URL it would not show up in the media select frame.

Hard to pinpoint and reproduce the steps to reproduce the issues I found, but after tweaking things for awhile I got it to a state where I wasn't able to encounter any further oddities: fbdb3e0

If that all looks and tests well for you, please confirm and then I'll commit.

/cc @melchoyce

@timmyc

This comment has been minimized.

Show comment
Hide comment
@timmyc

timmyc Aug 14, 2017

Collaborator

Thanks for the updates there @westonruter - makes perfect sense that the linkUrl should trigger a preview update - good catch there.

Collaborator

timmyc commented Aug 14, 2017

Thanks for the updates there @westonruter - makes perfect sense that the linkUrl should trigger a preview update - good catch there.

@westonruter

This comment has been minimized.

Show comment
Hide comment
@westonruter

westonruter Aug 14, 2017

Member

Committed to trunk in r41252.

Member

westonruter commented Aug 14, 2017

Committed to trunk in r41252.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment