New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Title Focus Issue While Creating New Posts #209

Closed
ahmadawais opened this Issue Aug 1, 2016 · 5 comments

Comments

Projects
None yet
2 participants
@ahmadawais
Contributor

ahmadawais commented Aug 1, 2016

This is UX flow issue. When I click the + button to create a new post, the first thing I want to do is add a title. Here's where I face a UX glitch.

Current UX-Flow

  • Click the + button
  • Either press tab to select the title or click on the title (which BTW doesn't pre-select the existing value i.e. (no title)) and add a new title.

Better UX-Flow would be:

  • Click the + button
  • The title element is pre-focused, i.e. (no title) value is pre-selected and all I have to do is type the title.


@ahmadawais ahmadawais changed the title from Title Focus Issue to Title Focus Issue While Creating New Posts Aug 1, 2016

@ahmadawais

This comment has been minimized.

Show comment
Hide comment
@ahmadawais

ahmadawais Aug 1, 2016

Contributor

There should be a way for adding tabindex="n" (where n is the number of each control) to WP_Customize_Dynamic_Control type for each control. That would bring the focus right where it belongs.

Contributor

ahmadawais commented Aug 1, 2016

There should be a way for adding tabindex="n" (where n is the number of each control) to WP_Customize_Dynamic_Control type for each control. That would bring the focus right where it belongs.

@westonruter

This comment has been minimized.

Show comment
Hide comment
@westonruter

westonruter Aug 2, 2016

Member

@ahmadawais this should be fixed in #206. Could you test it?

Member

westonruter commented Aug 2, 2016

@ahmadawais this should be fixed in #206. Could you test it?

@ahmadawais

This comment has been minimized.

Show comment
Hide comment
@ahmadawais

ahmadawais Aug 2, 2016

Contributor

@westonruter Just tested it, UX Flow is still broken.

  • Clicking on the input selects all, which is good!
  • Auto-focus on the title (Currently, I have to press TAB or click with the pad. It should be autofocused)
Contributor

ahmadawais commented Aug 2, 2016

@westonruter Just tested it, UX Flow is still broken.

  • Clicking on the input selects all, which is good!
  • Auto-focus on the title (Currently, I have to press TAB or click with the pad. It should be autofocused)
@westonruter

This comment has been minimized.

Show comment
Hide comment
@westonruter

westonruter Aug 2, 2016

Member

@ahmadawais sure enough, it isn't working for me now either. I just amended the PR with another commit which may fix the issue: cf224e2

Could you re-try? It's not pretty how we currently have to include these delay/defer calls.

Member

westonruter commented Aug 2, 2016

@ahmadawais sure enough, it isn't working for me now either. I just amended the PR with another commit which may fix the issue: cf224e2

Could you re-try? It's not pretty how we currently have to include these delay/defer calls.

@ahmadawais

This comment has been minimized.

Show comment
Hide comment
@ahmadawais

ahmadawais Aug 2, 2016

Contributor

@westonruter Yep! Now it is working but the 500 delay is too much. I set it to 100 and it works fine.

Talking about the customize-posts-panel.js file Line # 198

Change

}, 500 );

to

}, 100 );
Contributor

ahmadawais commented Aug 2, 2016

@westonruter Yep! Now it is working but the 500 delay is too much. I set it to 100 and it works fine.

Talking about the customize-posts-panel.js file Line # 198

Change

}, 500 );

to

}, 100 );
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment