Permalink
Browse files

Removed Java 1.8 no more necessary version checking (fixes issue #147)

Java 1.8 is by the way now a prerequisite to run from latest sources.
  • Loading branch information...
luccioman committed Dec 8, 2017
1 parent d95b288 commit 640fed2a9c063fa57b70f07903a9eff502f5dc99
Showing with 0 additions and 13 deletions.
  1. +0 −9 htroot/Status.html
  2. +0 −4 htroot/Status.java
@@ -170,15 +170,6 @@
</dd>
#(/hintCrawlMonitor)#
#(hintJREVersion)#::
<dt class="hintIcon"><img src="env/grafics/idea.png" width="32" height="32" alt="idea"/></dt>
<dd class="hint">
Your Java version is old. YaCy currently needs Java 1.7 but we want to migrate to Java 1.8 in the future.
Migration to 1.8 won't happen until end of 2016, but we want to join code with YaCy's sister project <a href="http://loklak.org">loklak.org</a>
and with a possible re-construction of YaCy in the <a href="http://kaskelix.de">kaskelix</a> architecture which will be using Java 1.8
</dd>
#(/hintJREVersion)#
#(hintSupport)#::
<dt class="hintIcon"><img src="env/grafics/idea.png" width="32" height="32" alt="idea"/></dt>
<dd class="hint">If you need professional support, please write to <tt>support@yacy.net</tt><br>For community support, please visit our <a href="http://forum.yacy.de" target="_blank">forum</a>.
@@ -173,10 +173,6 @@ public static serverObjects respond(
prop.put("hintCrawlMonitor", "1");
}
if (!System.getProperty("java.version").startsWith("1.8")) {
prop.put("hintJREVersion", "1");
}
if (adminaccess && "intranet|webportal|allip".indexOf(env.getConfig(SwitchboardConstants.NETWORK_NAME, "unspecified")) >= 0) {
prop.put("hintSupport", "1");
}

0 comments on commit 640fed2

Please sign in to comment.