Skip to content


Subversion checkout URL

You can clone with
Download ZIP


fix issue #496 Compatibility with Node.js 0.8 #498

merged 1 commit into from

3 participants


edit package.json:

    "engines": {
        "node": ">0.4",
        "npm": ">1.0"

also removed obsolete yahoo.buzilla


Well, that seems to be a bit more than what I was requesting...
Does this say Mojito isn't compatible with Node 4.x, or NPM 1.x?

hm, it says any node greater than 0.4 and npm greater than 1.0, but not including these exact versions.

do you want me to update to >=? However, I think a scenario where the patch version is zero and a benefit of any kind is unlikely.

To summarize our chat: we want to declare Mojito compatible will all versions of Node, starting with Node 0.4.x
Same for NPM 1.x.
Where 'x' is the latest version.


Yes, those conditions are met by this pr. See


thanks Isao!
"> 0.4" is equivalent to ">= 0.4.0"



@isao isao merged commit 87e7c98 into yahoo:develop

1 check passed

Details default The Travis build passed
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Sep 13, 2012
  1. @isao
This page is out of date. Refresh to see the latest.
Showing with 2 additions and 6 deletions.
  1. +2 −6 package.json
8 package.json
@@ -44,8 +44,8 @@
"mojito": "bin/mojito"
"engines": {
- "node": ">= 0.4.0 < 0.7.0",
- "npm": ">= 1.0.0"
+ "node": ">0.4",
+ "npm": ">1.0"
"devDependencies": {
"node-static": "~0.6.1",
@@ -62,10 +62,6 @@
"test": "./tests/run.js test -u --group server --driver nodejs && ./tests/run.js test -u --group client --driver selenium"
"yahoo": {
- "bugzilla": {
- "product": "Mojito",
- "component": "General"
- },
"mojito": {
"type": "bundle",
"location": "lib/app"
Something went wrong with that request. Please try again.