fix issue #496 Compatibility with Node.js 0.8 #498

Merged
merged 1 commit into from Sep 13, 2012

Projects

None yet

3 participants

@isao
Contributor
isao commented Sep 13, 2012

edit package.json:

    "engines": {
        "node": ">0.4",
        "npm": ">1.0"
    },

also removed obsolete yahoo.buzilla

@rwaldura

Well, that seems to be a bit more than what I was requesting...
Does this say Mojito isn't compatible with Node 4.x, or NPM 1.x?

Owner
isao replied Sep 13, 2012

hm, it says any node greater than 0.4 and npm greater than 1.0, but not including these exact versions.

do you want me to update to >=? However, I think a scenario where the patch version is zero and a benefit of any kind is unlikely.

To summarize our chat: we want to declare Mojito compatible will all versions of Node, starting with Node 0.4.x
Same for NPM 1.x.
Where 'x' is the latest version.

@isao
Contributor
isao commented Sep 13, 2012

Yes, those conditions are met by this pr. See https://gist.github.com/3717231

@rwaldura
Contributor

thanks Isao!
"> 0.4" is equivalent to ">= 0.4.0"

@drewfish
Member

+1

@isao isao merged commit 87e7c98 into yahoo:develop Sep 13, 2012

1 check passed

default The Travis build passed
Details
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment