Permalink
Commits on May 21, 2017
  1. Version 0.6.0

    dnrce committed May 21, 2017
  2. Pass sort keys to Arel as a list rather than an Array (#119)

    dnrce committed May 21, 2017
    Now always generate an array to be a bit clearer, but splat it when used.
    
    Fixes #115
Commits on May 20, 2017
  1. Support Rails 5.1 (#117)

    dnrce committed May 20, 2017
    Fixes #116
  2. Test on Travis's newer infrastructure (#118)

    dnrce committed May 20, 2017
    Fixes builds on 1.9.2.
    
    Also enable bundle caching.
Commits on Mar 25, 2017
  1. Fix quote type cast deprecation (#103)

    yoneapp authored and dnrce committed Mar 25, 2017
  2. Update bundler version

    dnrce committed Mar 25, 2017
  3. Test against Ruby 2.4

    dnrce committed Mar 25, 2017
    Integer changes in 2.4 require arel >= 6, which means Rails >= 4.2.
  4. Test against Rails 5.1.rc

    dnrce committed Mar 23, 2017
  5. Version 0.5.0

    dnrce committed Mar 25, 2017
Commits on Mar 24, 2017
Commits on Mar 21, 2017
  1. Unpin gems that were locked to older versions for test compatibility

    dnrce committed Mar 21, 2017
    No longer needed because bundler 1.14 honors required_ruby_version
    when resolving dependencies.
Commits on Oct 2, 2016
  1. Version 0.4.2

    dnrce committed Oct 2, 2016
    Skipping 0.4.1 due to a mistaken push to RubyGems
  2. Add a failing test for #50

    dnrce committed Oct 2, 2016
Commits on Jul 10, 2016
  1. Version 0.4.0

    dnrce committed Jul 10, 2016
  2. Merge pull request #101 from dnrce/rails-5.0

    jrgifford committed Jul 10, 2016
    Add Rails 5.0 support
Commits on Jul 9, 2016
  1. Add Rails 5.0 support

    dnrce committed Jul 9, 2016
    Fixes #100, closes #88, closes #92
Commits on May 16, 2016
  1. Merge pull request #98 from dnrce/mime-types-version

    dnrce committed May 16, 2016
    Fix more CI dependency problems for old Rubies
Commits on Jan 10, 2016
  1. Merge pull request #89 from dnrce/rack-cache

    dnrce committed Jan 10, 2016
    Fix CI dependency problems
  2. Travis: Update bundler before installing gems

    dnrce committed Jan 7, 2016
    Some versions of bundler are affected by a bug that causes them to throw
    
        NoMethodError: undefined method `spec' for nil:NilClass
    
    during installation of the yaml_db gem. This bug was fixed in bundler@a0c90cd, but several of
    Travis's Ruby environments are based on older affected versions. To resolve, we force an update.
Commits on Jan 6, 2016
Commits on May 8, 2015
  1. Merge pull request #79 from jordan-brough/fix-file-flushing

    jrgifford committed May 8, 2015
    File flushing fix
Commits on May 6, 2015
  1. File flushing fix

    jordan-brough committed May 6, 2015
    Use the block form of `File.open` when writing to a file.  This ensures that the
    file gets flushed to disk when finished.
    
    This is a problem when running tasks like `Rake::Task['db:data:dump'].invoke`.
    
    It hasn't been not a problem for `rake db:data:dump` because open files get
    flushed automatically when rake finishes and ruby terminates.
Commits on Feb 9, 2015
  1. Remove mention of Rails 2.x

    dnrce committed Feb 9, 2015
Commits on Dec 25, 2014
  1. Test with Ruby 2.2

    dnrce committed Dec 25, 2014
Commits on Dec 24, 2014
  1. Hold i18n back for older Rubies

    dnrce committed Dec 24, 2014
    Fixes #75
Commits on Nov 18, 2014
  1. Merge pull request #73 from dnrce/namespace

    dnrce committed Nov 18, 2014
    Move everything under the YamlDb namespace
Commits on Nov 17, 2014
  1. Remove init.rb

    dnrce committed Nov 17, 2014
    Was used for Rails 2.x-style plugin loading.
    No longer needed for use as a gem.