Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Update Ruby and loosen gem specifications

* Update Ruby to 1.9.3-p327 via .rvmrc
* Specified gems set to update until next major version
* Fix bourne deprecation error
  • Loading branch information...
commit 7b120d69cefb3f3d80ee69ad9ce4244e3ae04081 1 parent 88f3ded
Adarsh Pandit authored
Showing with 74 additions and 67 deletions.
  1. +1 −1  .rvmrc
  2. +15 −15 Gemfile
  3. +57 −51 Gemfile.lock
  4. +1 −0  spec/spec_helper.rb
View
2  .rvmrc
@@ -1 +1 @@
-rvm 1.9.3
+rvm 1.9.3-p327
View
30 Gemfile
@@ -7,26 +7,26 @@ gem 'rails', '~> 3.2'
# Gems used only for assets and not required
# in production environments by default.
group :assets do
- gem 'sass-rails', '~> 3.2.3'
- gem 'coffee-rails', '~> 3.2.1'
- gem 'uglifier', '>= 1.0.3'
+ gem 'coffee-rails', '~> 3.2'
+ gem 'sass-rails', '~> 3.2'
+ gem 'uglifier', '>= 1.0'
end
-gem 'airbrake', '~> 3.1.0'
+gem 'airbrake', '~> 3.1'
gem 'attr_encrypted'
gem 'awesome_print'
-gem 'bourbon', '~> 2.1.1'
+gem 'bourbon', '~> 2.1'
gem 'delayed_job_active_record'
gem 'draper'
gem 'flutie'
gem 'formtastic'
-gem 'high_voltage', '~> 1.2.0'
+gem 'high_voltage', '~> 1.2'
gem 'hirefireapp'
gem 'jquery-rails'
gem 'newrelic_rpm'
gem 'omniauth', '~> 1.0'
gem 'omniauth-yammer'
-gem 'paperclip', '~> 3.0.4'
+gem 'paperclip', '~> 3.0'
gem 'pg'
gem 'rest-client'
gem 'sass'
@@ -34,8 +34,8 @@ gem 'strip_attributes', '~> 1.1'
gem 'swfobject-rails'
gem 'tddium'
gem 'thin'
-gem 'underscore-rails', '~> 1.3.1'
-gem 'zero-clipboard-rails', '~> 1.0.1'
+gem 'underscore-rails', '~> 1.3'
+gem 'zero-clipboard-rails', '~> 1.0'
# We currently use this forked repo as it allows you to nest links to add associations.
# We can move back to the original gem when the gem fixes a bug where nesting causes
@@ -44,7 +44,7 @@ gem 'cocoon', git: 'git://github.com/jsteiner/cocoon.git', branch: 'scheddo'
group :development do
gem 'bundler', '>= 1.2.0.pre'
- gem 'foreman', '~> 0.46.0'
+ gem 'foreman', '~> 0.46'
gem 'quiet_assets'
end
@@ -61,18 +61,18 @@ group :development, :test, :tddium_ignore do
end
group :test do
- gem 'bourne'
+ gem 'bourne', require: false
gem 'capybara-webkit', '~> 0.12.0'
gem 'database_cleaner'
gem 'email_spec'
gem 'factory_girl_rails', '~> 3.0'
gem 'launchy'
- gem 'shoulda-matchers', '~> 1.4.1'
- gem 'simplecov', :require => false
+ gem 'shoulda-matchers', '~> 1.4'
+ gem 'simplecov', require: false
gem 'sinatra'
gem 'timecop'
- gem 'turnip', '~> 1.0.0'
- gem 'mocha', '~> 0.9.8'
+ gem 'turnip', '~> 1.0'
+ gem 'mocha'
end
group :staging, :production do
View
108 Gemfile.lock
@@ -8,31 +8,31 @@ GIT
GEM
remote: https://rubygems.org/
specs:
- actionmailer (3.2.8)
- actionpack (= 3.2.8)
+ actionmailer (3.2.9)
+ actionpack (= 3.2.9)
mail (~> 2.4.4)
- actionpack (3.2.8)
- activemodel (= 3.2.8)
- activesupport (= 3.2.8)
+ actionpack (3.2.9)
+ activemodel (= 3.2.9)
+ activesupport (= 3.2.9)
builder (~> 3.0.0)
erubis (~> 2.7.0)
journey (~> 1.0.4)
rack (~> 1.4.0)
rack-cache (~> 1.2)
rack-test (~> 0.6.1)
- sprockets (~> 2.1.3)
- activemodel (3.2.8)
- activesupport (= 3.2.8)
+ sprockets (~> 2.2.1)
+ activemodel (3.2.9)
+ activesupport (= 3.2.9)
builder (~> 3.0.0)
- activerecord (3.2.8)
- activemodel (= 3.2.8)
- activesupport (= 3.2.8)
+ activerecord (3.2.9)
+ activemodel (= 3.2.9)
+ activesupport (= 3.2.9)
arel (~> 3.0.2)
tzinfo (~> 0.3.29)
- activeresource (3.2.8)
- activemodel (= 3.2.8)
- activesupport (= 3.2.8)
- activesupport (3.2.8)
+ activeresource (3.2.9)
+ activemodel (= 3.2.9)
+ activesupport (= 3.2.9)
+ activesupport (3.2.9)
i18n (~> 0.6)
multi_json (~> 1.0)
addressable (2.3.2)
@@ -46,8 +46,8 @@ GEM
bourbon (2.1.2)
sass (>= 3.2)
thor
- bourne (1.0)
- mocha (= 0.9.8)
+ bourne (1.2.0)
+ mocha (= 0.12.3)
builder (3.0.4)
capybara (1.1.3)
mime-types (>= 1.16)
@@ -73,7 +73,7 @@ GEM
connection_pool (0.9.2)
daemons (1.1.9)
database_cleaner (0.9.1)
- delayed_job (3.0.3)
+ delayed_job (3.0.4)
activesupport (~> 3.0)
delayed_job_active_record (0.3.3)
activerecord (>= 2.1.0, < 4)
@@ -106,14 +106,15 @@ GEM
multipart-post (~> 1.1)
ffi (1.1.5)
flutie (1.3.3)
- foreman (0.46.0)
+ foreman (0.60.2)
thor (>= 0.13.6)
formtastic (2.2.1)
actionpack (>= 3.0)
gherkin (2.11.5)
json (>= 1.4.6)
- girl_friday (0.10.0)
+ girl_friday (0.11.1)
connection_pool (~> 0.9.0)
+ rubinius-actor
hashie (1.2.0)
high_voltage (1.2.1)
highline (1.6.15)
@@ -142,10 +143,11 @@ GEM
treetop (~> 1.4.8)
mail_view (1.0.3)
tilt
+ metaclass (0.0.1)
method_source (0.8.1)
mime-types (1.19)
- mocha (0.9.8)
- rake
+ mocha (0.12.3)
+ metaclass (~> 0.0.1)
multi_json (1.3.7)
multi_xml (0.5.1)
multipart-post (1.1.5)
@@ -165,11 +167,11 @@ GEM
omniauth (~> 1.0)
omniauth-yammer (0.0.4)
omniauth-oauth2 (>= 1.1)
- paperclip (3.0.4)
+ paperclip (3.3.1)
activemodel (>= 3.0.0)
activerecord (>= 3.0.0)
activesupport (>= 3.0.0)
- cocaine (>= 0.0.2)
+ cocaine (~> 0.4.0)
mime-types
pg (0.14.1)
polyglot (0.3.3)
@@ -188,22 +190,22 @@ GEM
rack
rack-test (0.6.2)
rack (>= 1.0)
- rails (3.2.8)
- actionmailer (= 3.2.8)
- actionpack (= 3.2.8)
- activerecord (= 3.2.8)
- activeresource (= 3.2.8)
- activesupport (= 3.2.8)
+ rails (3.2.9)
+ actionmailer (= 3.2.9)
+ actionpack (= 3.2.9)
+ activerecord (= 3.2.9)
+ activeresource (= 3.2.9)
+ activesupport (= 3.2.9)
bundler (~> 1.0)
- railties (= 3.2.8)
- railties (3.2.8)
- actionpack (= 3.2.8)
- activesupport (= 3.2.8)
+ railties (= 3.2.9)
+ railties (3.2.9)
+ actionpack (= 3.2.9)
+ activesupport (= 3.2.9)
rack-ssl (~> 1.3.2)
rake (>= 0.8.7)
rdoc (~> 3.4)
thor (>= 0.14.6, < 2.0)
- rake (0.9.2.2)
+ rake (10.0.0)
rdoc (3.12)
json (~> 1.4)
rest-client (1.6.7)
@@ -221,8 +223,11 @@ GEM
activesupport (>= 3.0)
railties (>= 3.0)
rspec (~> 2.9.0)
+ rubinius-actor (0.0.2)
+ rubinius-core-api
+ rubinius-core-api (0.0.1)
rubyzip (0.9.9)
- sass (3.2.2)
+ sass (3.2.3)
sass-rails (3.2.5)
railties (~> 3.2.0)
sass (>= 3.1.10)
@@ -245,8 +250,9 @@ GEM
rack-protection (~> 1.2)
tilt (~> 1.3, >= 1.3.3)
slop (3.3.3)
- sprockets (2.1.3)
+ sprockets (2.2.1)
hike (~> 1.2)
+ multi_json (~> 1.0)
rack (~> 1.0)
tilt (~> 1.1, != 1.3.0)
sprockets-redirect (0.1.0)
@@ -282,7 +288,7 @@ GEM
uglifier (1.3.0)
execjs (>= 0.3.0)
multi_json (~> 1.0, >= 1.0.2)
- underscore-rails (1.3.1)
+ underscore-rails (1.4.2.1)
xpath (0.1.4)
nokogiri (~> 1.3)
zero-clipboard-rails (1.0.1)
@@ -293,15 +299,15 @@ PLATFORMS
ruby
DEPENDENCIES
- airbrake (~> 3.1.0)
+ airbrake (~> 3.1)
attr_encrypted
awesome_print
- bourbon (~> 2.1.1)
+ bourbon (~> 2.1)
bourne
bundler (>= 1.2.0.pre)
capybara-webkit (~> 0.12.0)
cocoon!
- coffee-rails (~> 3.2.1)
+ coffee-rails (~> 3.2)
database_cleaner
delayed_job_active_record
dotenv
@@ -310,18 +316,18 @@ DEPENDENCIES
evergreen
factory_girl_rails (~> 3.0)
flutie
- foreman (~> 0.46.0)
+ foreman (~> 0.46)
formtastic
- high_voltage (~> 1.2.0)
+ high_voltage (~> 1.2)
hirefireapp
jquery-rails
launchy
mail_view
- mocha (~> 0.9.8)
+ mocha
newrelic_rpm
omniauth (~> 1.0)
omniauth-yammer
- paperclip (~> 3.0.4)
+ paperclip (~> 3.0)
pg
pry
quiet_assets
@@ -329,9 +335,9 @@ DEPENDENCIES
rest-client
rspec-rails (~> 2.9.0)
sass
- sass-rails (~> 3.2.3)
+ sass-rails (~> 3.2)
sham_rack
- shoulda-matchers (~> 1.4.1)
+ shoulda-matchers (~> 1.4)
simplecov
sinatra
sprockets-redirect
@@ -340,7 +346,7 @@ DEPENDENCIES
tddium
thin
timecop
- turnip (~> 1.0.0)
- uglifier (>= 1.0.3)
- underscore-rails (~> 1.3.1)
- zero-clipboard-rails (~> 1.0.1)
+ turnip (~> 1.0)
+ uglifier (>= 1.0)
+ underscore-rails (~> 1.3)
+ zero-clipboard-rails (~> 1.0)
View
1  spec/spec_helper.rb
@@ -14,6 +14,7 @@
require 'rspec/autorun'
require 'turnip/capybara'
require 'email_spec'
+require 'bourne'
# Requires supporting ruby files with custom matchers and macros, etc,
# in spec/support/ and its subdirectories.
Please sign in to comment.
Something went wrong with that request. Please try again.