Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Undeclared dependency FFI::Platypus::Type::StringArray #5

Open
eserte opened this issue Mar 19, 2019 · 0 comments

Comments

Projects
None yet
1 participant
@eserte
Copy link

commented Mar 19, 2019

See subject. The test suite fails without this dependency:

#   Failed test 'Term/Caca.pm loaded ok'
#   at t/00-compile.t line 51.
#          got: '512'
#     expected: '0'
Can't locate FFI/Platypus/Type/StringArray.pm in @INC (you may need to install the FFI::Platypus::Type::StringArray module) (@INC contains: ... .) at (eval 53) line 1.
BEGIN failed--compilation aborted at (eval 53) line 1.
FFI::Platypus::Type::StringArray does not appear to conform to the custom type API at /home/cpansand/.cpan/build/2019031901/Term-Caca-3.0.1-0/blib/lib/Term/Caca/FFI.pm line 61.
Compilation failed in require at /home/cpansand/.cpan/build/2019031901/Term-Caca-3.0.1-0/blib/lib/Term/Caca.pm line 15.
BEGIN failed--compilation aborted at /home/cpansand/.cpan/build/2019031901/Term-Caca-3.0.1-0/blib/lib/Term/Caca.pm line 15.
Compilation failed in require at -e line 1.

Or alternatively you want to increase the FFI::Platypus dependency version to 0.84 or so.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.