Can't find file to patch at input line 5 #17

Open
ggd543 opened this Issue Nov 16, 2011 · 2 comments

Comments

Projects
None yet
2 participants

ggd543 commented Nov 16, 2011

When I did as the document: patch -p1 < ./tcp.patch
I got the follow error:

can't find file to patch at input line 5
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
-------------------------------------------------
|diff --git a/src/core/ngx_log.c b/src/core/ngx_log.c
|index 770a590..26dd221 100644
|--- a/src/core/ngx_log.c
|+++ b/src/core/ngx_log.c
-------------------------------------------------
File to patch:

Then the shell seams to ask me to provide a file to patch.
What can i do ?

PS: My os is redhat 5

Owner

yaoweibin commented Nov 16, 2011

See the README:

$ cd nginx-0.7.65/
$ patch -p1< /path/to/nginx_tcp_proxy_module/tcp.patch

On 2011-11-16 12:13, 刘永健 wrote:

When I did as the document: patch -p1< ./tcp.patch
I got the follow error:

Perhaps you used the wrong -p or --strip option?

## The text leading up to this was:

|diff --git a/src/core/ngx_log.c b/src/core/ngx_log.c
|index 770a590..26dd221 100644
|--- a/src/core/ngx_log.c

## |+++ b/src/core/ngx_log.c

File to patch:

Then the shell seams to ask me to provide a file to patch.
What can i do ?

PS: My os is redhat 5


Reply to this email directly or view it on GitHub:
#17

Weibin Yao

@ggd543 ggd543 referenced this issue Nov 16, 2011

Open

Make error #19

@ghost

ghost commented Feb 2, 2013

Need more information.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment