Skip to content

yappabe/docker-php

master
Switch branches/tags
Code

Latest commit

 

Git stats

Files

Permalink
Failed to load latest commit information.
Type
Name
Latest commit message
Commit time
5.6
 
 
7.0
 
 
7.1
 
 
7.2
 
 
7.3
 
 
7.4
 
 
8.0
 
 
8.1
 
 
 
 
 
 
 
 

Docker pulls

Yappa PHP FPM Docker Image

Usage

Add the following to your docker-compose.yml file:

php:
    image: yappabe/php
    volumes_from:
        - app
    links:
        - mysql

PHP version

To use a specific PHP version, append the version number to the image name.

Eg: image: yappabe/php:7.4

The following PHP versions are available:

  • PHP 8.1RC6 (bullseye stable)
  • PHP 8.0 (bullseye stable)
  • PHP 7.4 (bullseye stable)
  • PHP 7.3 (bullseye stable)
  • PHP 7.2 (bullseye stable)
  • PHP 7.1 (bullseye stable)
  • PHP 7.0 (bullseye stable)
  • PHP 5.6 (bullseye stable)

Configurations

You can configure the following environment vars, these are the defaults.

ENV ENVIRONMENT dev
ENV PHP_FPM_USER www-data
ENV PHP_FPM_PORT 9000
ENV PHP_ERROR_REPORTING "E_ALL \& ~E_NOTICE \& ~E_STRICT \& ~E_DEPRECATED"

Development and permissions

Run php-fpm process as root user to avoid cli and fpm permission issues. Never ever use this in production!

ENV PHP_FPM_USER root

About

Docker images for easy php development, using php-fpm

Resources

Stars

Watchers

Forks

Packages

No packages published