New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

The registry shows package could not be found even though yarnpg.com shows it exists #6697

Closed
DAlperin opened this Issue Nov 18, 2018 · 1 comment

Comments

Projects
None yet
3 participants
@DAlperin

DAlperin commented Nov 18, 2018

When I yarn install in my project yarn trys to install the package har-validator. I have verified that the package exists and yet it fails with the error: error https://registry.yarnpkg.com/har-validator/-/har-validator-5.1.2.tgz: Extracting tar content of undefined failed, the file appears to be corrupt: "Unexpected end of data" When I visit the url to see if the package is there I get the error {"error":"package could not be found."} NPM seems to install it fine.

Fedora 28
Node 8.12.0
Yarn 1.12.3

@heupr heupr bot assigned arcanis Nov 18, 2018

@heupr heupr bot added the triaged label Nov 18, 2018

@Daniel15

This comment has been minimized.

Member

Daniel15 commented Nov 18, 2018

har-validator 5.1.2 was unpublished. You're likely hitting a cache which still has the old version, which is why it's still working for npm. It won't keep working forever. See ahmadnassri/node-har-validator#112

@Daniel15 Daniel15 closed this Nov 18, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment