Skip to content
Permalink
Browse files

Merge pull request #83 from yast/ci_integration

Ci integration
  • Loading branch information...
jreidinger committed Oct 2, 2013
2 parents 5e5f2ce + cfb17b7 commit a967f16ac99d0466570fe1a40a0a249d35e159f1
Showing with 15 additions and 17 deletions.
  1. +1 −0 .gitignore
  2. +0 −6 CMakeLists.txt
  3. +7 −0 Rakefile
  4. +1 −0 VERSION
  5. +2 −2 VERSION.cmake
  6. +4 −9 yast2-ruby-bindings.spec.in → package/yast2-ruby-bindings.spec
@@ -1,3 +1,4 @@
/doc
/build
/.yardoc
/package/*.tar.*
@@ -49,9 +49,3 @@ enable_testing()

add_subdirectory(tests)

#
# packaging
#
set(RPMNAME "yast2-ruby-bindings")

generate_packaging(${RPMNAME} ${VERSION})
@@ -0,0 +1,7 @@
require "yast/rake"

Packaging.configuration do |conf|
#lets ignore license check for now
conf.skip_license_check << /.*/
end

@@ -0,0 +1 @@
3.1.0
@@ -1,3 +1,3 @@
SET(VERSION_MAJOR "3")
SET(VERSION_MINOR "0")
SET(VERSION_PATCH "3")
SET(VERSION_MINOR "1")
SET(VERSION_PATCH "0")
@@ -1,12 +1,9 @@


#
# spec file for package yast2-ruby-bindings (Version 0.1)
# spec file for package yast2-ruby-bindings
#
# norootforbuild

Name: yast2-ruby-bindings
Version: @VERSION@
Version: 3.1.0
Release: 0
License: GPL-2.0
Group: System/YaST
@@ -19,12 +16,12 @@ BuildRequires: yast2-devtools >= 2.16.3
# libzypp-devel is missing .la requires
BuildRequires: ruby-devel
BuildRequires: rubygem-fast_gettext
Requires: rubygem-fast_gettext
Requires: rubygem-fast_gettext
Requires: yast2-core >= 2.24.0
BuildRequires: yast2-core-devel >= 2.24.0
Requires: yast2-ycp-ui-bindings >= 2.21.9
BuildRequires: yast2-ycp-ui-bindings-devel >= 2.21.9
Requires: ruby
Requires: ruby
Summary: Ruby bindings for the YaST platform

%description
@@ -55,8 +52,6 @@ cd build/tests/ruby
make test ARGS=-V
cd -

@CLEAN@

%files
%defattr (-, root, root)
%{_libdir}/YaST2/plugin/libpy2lang_ruby.so

0 comments on commit a967f16

Please sign in to comment.
You can’t perform that action at this time.