Skip to content
Permalink
Browse files

Replace idnconv dependency with simpleidn

  • Loading branch information...
imobachgs committed Jan 31, 2018
1 parent 4b2e779 commit a30d96b2a2723b431cb668eb85ecfe471de4271a
Showing with 4 additions and 7 deletions.
  1. +4 −7 package/yast2.spec
@@ -38,6 +38,8 @@ BuildRequires: rubygem(%{rb_default_ruby_abi}:cheetah)
BuildRequires: update-desktop-files
# For running RSpec tests during build
BuildRequires: rubygem(%{rb_default_ruby_abi}:rspec)
# For converting to/from punycode strings
BuildRequires: rubygem(%{rb_default_ruby_abi}:simpleidn)
# Needed already in build time
BuildRequires: yast2-core >= 2.18.12
BuildRequires: yast2-devtools >= 3.1.10
@@ -65,6 +67,8 @@ Requires: perl-XML-Simple
Requires: rubygem(%{rb_default_ruby_abi}:abstract_method)
# for file access using augeas
Requires: rubygem(%{rb_default_ruby_abi}:cfa)
# For converting to/from punycode strings
Requires: rubygem(%{rb_default_ruby_abi}:simpleidn)
Requires: sysconfig >= 0.80.0
# for running scripts
Requires: rubygem(%{rb_default_ruby_abi}:cheetah)
@@ -95,13 +99,6 @@ Conflicts: yast2-mail < 3.1.7
# Older packager use removed API
Conflicts: yast2-packager < 4.0.33
BuildRoot: %{_tmppath}/%{name}-%{version}-build
# for Punycode.rb (bnc#651893) - the idnconv tool is located in
# different packages (SLE12/Leap-42.1: bind-utils, TW/Factory: idnkit)
%if 0%{?suse_version} >= 1330
Requires: idnkit
%else
Requires: bind-utils
%endif
Obsoletes: yast2-devel-doc
# for the PackageExtractor class, just make sure they are present,
# these should be present even in a very minimal installation

0 comments on commit a30d96b

Please sign in to comment.
You can’t perform that action at this time.