Generator creates usemin block for require which is no longer supported. #296

Closed
bmatto opened this Issue Oct 15, 2014 · 8 comments

Projects

None yet

7 participants

@bmatto
bmatto commented Oct 15, 2014

Getting all set to build and ran "grunt", got this error 'Fatal error: require.js blocks are no more supported.'. Found this ... yeoman/grunt-usemin#112. Are there plans to change the scaffold in regards to this incompatibility?

@John3x
John3x commented Oct 16, 2014

I've got the same issue.

@omasback

+1. Can't build now.

@omasback

A temporary workaround is to roll back usemin version to 0.1.13. The build seems to work fine with the older version. (well except for having to replace imagemin with copy, but that's another issue for another day)

@bmatto
bmatto commented Oct 21, 2014

@omasback thanks for the workaround.

@danne931

thanks @omasback !

@charneykaye

I would not call this an effective workaround, y'all. Searching for an alternative yeoman/grunt-usemin#112

@gpolyn
gpolyn commented Jun 19, 2015

Having same issue. Feels like generator-backbone is sidelined for now.

@marian-r marian-r added a commit to marian-r/generator-backbone that referenced this issue Nov 22, 2015
@marian-r marian-r Replace RequireJS with Almond during build [fixes #296] e59886b
@ruyadorno ruyadorno closed this in 2cacbea Nov 22, 2015
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment