yeoman update issue #749

Closed
ehutch79 opened this Issue Nov 28, 2012 · 3 comments

Projects

None yet

4 participants

@ehutch79

I'm playing around with yeoman, and noticed the copy of angular was outdated (1.0.1 instead of 1.0.2) and thought to myself, "i wonder how one updates libraries in yeoman" and tried the yeoman update command and got this:

$ yeoman update
Running "bower:update" (bower) task
Could not find local component.json

google doesn't seem to reveal anything. this was on a bare 'yeoman init angular' project. No changes had been made yet. I also couldnt find any issues on github about this.

@thomasmery

Hi,

I also noticed that when installing a component (namely popcorn-js) the
version pulled was not the latest from github - when the uri was the actual
project github uri

was wondering if Bower was caching the packages ?

thnks

On Wed, Nov 28, 2012 at 2:08 AM, Eric Hutchinson
notifications@github.comwrote:

I'm playing around with yeoman, and noticed the copy of angular was
outdated (1.0.1 instead of 1.0.2) and thought to myself, "i wonder how one
updates libraries in yeoman" and tried the yeoman update command and got
this:

$ yeoman update
Running "bower:update" (bower) task
Could not find local component.json

google doesn't seem to reveal anything. this was on a bare 'yeoman init
angular' project. No changes had been made yet. I also couldnt find any
issues on github about this.


Reply to this email directly or view it on GitHubhttps://github.com/yeoman/yeoman/issues/749.


http://www.thomas-mery.net

@cobbweb
cobbweb commented Nov 29, 2012

I haven't used the Angular generator before, but at the moment those custom generators (backbone, ember, etc) include hard copies of resources, they aren't managed by bower yet.

yeoman install and yeoman update delegate to bower, so you can create a component.json in your project root and add angular with your desired version. Future releases of yeoman will get the generators working with bower. (I think if you run yeoman install angular --save it will automatically add it to component.json)

@sindresorhus
Member

You need to manually update for now. Dependencies through Bower will come in 1.0.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment