Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Update setup/install.sh #697

Closed
wants to merge 1 commit into from

2 participants

@mpathy

All packages needed for Yeoman are already available in the ubuntu repository.
I added information for the missing ones in the shell script.
Using a repository is normally a good idea, because it provides security updates automatically.

I am no native english speaker so change the words to a better sounding version :)

@mpathy mpathy Update setup/install.sh
All packages needed for Yeoman are available in the repository.
Added information for the missing ones in the shell script.
I am no native english speaker so change the words to a better sounding version :)
3839ffb
@sindresorhus
Owner

We just got a PR #696 for a big change to that script, can you open a PR on the repo of that repo?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Nov 5, 2012
  1. @mpathy

    Update setup/install.sh

    mpathy authored
    All packages needed for Yeoman are available in the repository.
    Added information for the missing ones in the shell script.
    I am no native english speaker so change the words to a better sounding version :)
This page is out of date. Refresh to see the latest.
Showing with 2 additions and 0 deletions.
  1. +2 −0  setup/install.sh
View
2  setup/install.sh
@@ -173,6 +173,7 @@ audit() {
[ "$node" -eq 0 ] && \
sad_print "NodeJS" "" && \
desc_print "I recommend you grab a fresh NodeJS install (>= 0.8.x) from http://nodejs.org/download/ "
+ desc_print "On Ubuntu," "sudo apt-get install nodejs" "should do the trick, but if the version is too old, better install it manual instead."
[ "$ruby" -eq 0 ] && \
sad_print "ruby" "" && \
desc_print "Check your ruby version is adequate with" "ruby -v" "(>= 1.8.7 required) and install http://www.ruby-lang.org/en/downloads/"
@@ -182,6 +183,7 @@ audit() {
[ "$compass" -eq 0 ] && \
sad_print "Compass" "" && \
desc_print "is not installed: http://compass-style.org/install/ "
+ desc_print "On Ubuntu," "sudo apt-get install ruby-compass" "should do the trick."
[ "$phantomjs" -eq 0 ] && \
sad_print "PhantomJS" "" && \
desc_print "Follow instructions at http://phantomjs.org/download.html - the binary installs are quick! " && \
Something went wrong with that request. Please try again.