Skip to content
Browse files

Add lilypond 2.14.2 for stable reazons

  • Loading branch information...
1 parent adec5ad commit ffd29549338947807ed3a9df012a3be8bb1952d0 @yermandu committed Mar 12, 2012
Showing with 110 additions and 0 deletions.
  1. +2 −0 media-sound/lilypond/Manifest
  2. +108 −0 media-sound/lilypond/lilypond-2.14.2.ebuild
View
2 media-sound/lilypond/Manifest
@@ -0,0 +1,2 @@
+DIST lilypond-2.14.2.tar.gz 15224418 RMD160 74123b2db40519feaf8144fd19becf3ad81738e7 SHA1 0ea657bb184d9d6a2e3f6bca91e6b0d62a3a013e SHA256 243a6b3845722a37083d73ed681e69ffde0b3b9c6158af20db3c0926dd982696
+EBUILD lilypond-2.14.2.ebuild 2685 RMD160 01c28340d42cba9caa343a97a226e511423f128b SHA1 d9bdae8829f7ebd0f9420f347ddb9f4cf85209a8 SHA256 0f68ab7a8de5561c1a5dfa86eb3a415d09903d26ea45af996933f8deb018c153
View
108 media-sound/lilypond/lilypond-2.14.2.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lilypond/lilypond-2.12.3.ebuild,v 1.9 2011/10/08 18:51:54 armin76 Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+
+inherit eutils versionator toolchain-funcs elisp-common flag-o-matic python autotools
+
+DESCRIPTION="GNU Music Typesetter"
+SRC_URI="http://download.linuxaudio.org/lilypond/sources/v$(get_version_component_range 1-2)/${P}.tar.gz"
+HOMEPAGE="http://lilypond.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~hppa x86"
+
+IUSE="debug emacs profile"
+
+RDEPEND="media-fonts/urw-fonts
+ >=media-libs/freetype-2
+ media-libs/fontconfig
+ >=x11-libs/pango-1.12.3
+ >=dev-scheme/guile-1.8.2[deprecated,regex]
+ || ( >=app-text/ghostscript-gnu-8.15
+ >=app-text/ghostscript-gpl-8.15 )
+ emacs? ( virtual/emacs )"
+
+DEPEND="${RDEPEND}
+ >=media-gfx/fontforge-20070501
+ dev-texlive/texlive-metapost
+ app-text/t1utils
+ >=app-text/mftrace-1.2.9
+ >=sys-apps/texinfo-4.11
+ sys-devel/make
+ sys-devel/gettext
+ sys-devel/flex
+ dev-lang/perl
+ >=sys-devel/bison-2.0"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ if [[ $(gcc-major-version) -lt 4 ]]; then
+ eerror "You need GCC 4.x to build this software."
+ die "you need to compile with gcc-4 or later"
+ fi
+
+ if use profile; then
+ einfo "Stripping -fomit-frame-pointer flag"
+ strip-flags -fomit-frame-pointer
+ fi
+
+ econf $(use_enable debug debugging) \
+ $(use_enable profile profiling) \
+ --disable-gui \
+ --disable-documentation
+}
+
+src_compile() {
+ # without -j1 it will not fail, but building docs later will, bug 236010
+ emake -j1 || die "emake failed"
+
+ if use emacs; then
+ elisp-compile elisp/lilypond-{font-lock,indent,mode,what-beat}.el \
+ || die "elisp-compile failed"
+ fi
+}
+
+# lilypond doesn't include the answers to the tests.
+# You are supposed to build those yourself with an
+# earlier version. Then running tests will compare the
+# results of the tests against the results from the
+# earlier version. As such, tests seem mostly useless
+# for our purposes.
+RESTRICT=test
+
+src_install() {
+ emake DESTDIR="${D}" vimdir=/usr/share/vim/vimfiles install || die "emake install failed"
+
+ # remove elisp files since they are in the wrong directory
+ rm -rf "${D}"/usr/share/emacs
+
+ if use emacs; then
+ elisp-install ${PN} elisp/*.{el,elc} elisp/out/*.el \
+ || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}"/50${PN}-gentoo.el
+ fi
+
+ dodoc AUTHORS.txt HACKING NEWS.txt README.txt || die
+
+ python_convert_shebangs -r 2 "${D}"
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}

0 comments on commit ffd2954

Please sign in to comment.
Something went wrong with that request. Please try again.