Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

sqlOnlySettings

  • Loading branch information...
commit 95e08a7afbbbe210432b955ef412a8e3282767de 1 parent a55709f
@snoyberg snoyberg authored
Showing with 3 additions and 3 deletions.
  1. +0 −1  Import.hs
  2. +1 −1  Model.hs
  3. +2 −1  PROJECTNAME.cabal
View
1  Import.hs
@@ -14,7 +14,6 @@ import Model as Import
import Settings as Import
import Settings.Development as Import
import Settings.StaticFiles as Import
-import Data.Aeson as Import (toJSON)
#if __GLASGOW_HASKELL__ >= 704
import Data.Monoid as Import
View
2  Model.hs
@@ -10,5 +10,5 @@ import Database.Persist.Quasi
-- You can find more information on persistent and how to declare entities
-- at:
-- http://www.yesodweb.com/book/persistent/
-share [mkPersist sqlSettings, mkMigrate "migrateAll"]
+share [mkPersist sqlOnlySettings, mkMigrate "migrateAll"]
$(persistFileWith lowerCaseSettings "config/models")
View
3  PROJECTNAME.cabal
@@ -42,7 +42,7 @@ library
build-depends: base >= 4 && < 5
-- , yesod-platform >= 1.1 && < 1.2
- , yesod >= 1.1.4 && < 1.2
+ , yesod >= 1.1.5 && < 1.2
, yesod-core >= 1.1.5 && < 1.2
, yesod-auth >= 1.1 && < 1.2
, yesod-static >= 1.1 && < 1.2
@@ -53,6 +53,7 @@ library
, text >= 0.11 && < 0.12
, persistent >= 1.1 && < 1.2
, persistent-postgresql >= 1.1 && < 1.2
+ , persistent-template >= 1.1.1 && < 1.2
, template-haskell
, hamlet >= 1.1 && < 1.2
, shakespeare-css >= 1.0 && < 1.1
Please sign in to comment.
Something went wrong with that request. Please try again.